multimedia/libva fails in configure stage, missing file?

Guido Falsi madpilot at FreeBSD.org
Mon Jan 12 08:55:24 UTC 2015


On 01/09/15 18:29, Thomas Mueller wrote:
> You pointed to libtoolize, which is installed as part of devel/libtool, and I found something strange.
> 
> Running 
> ls -l /usr/local/bin/lib*
> produced
> 
> -r-xr-xr-x  1 root  wheel    1952 Jul 16 00:31 /usr/local/bin/libIDL-config-2
> -r-xr-xr-x  1 root  wheel    2528 Jul  4  2014 /usr/local/bin/libassuan-config
> -r-xr-xr-x  1 root  wheel    3988 Dec 27 13:50 /usr/local/bin/libgcrypt-config
> -rwxr-xr-x  1 root  wheel   15731 Dec 30 08:47 /usr/local/bin/libnetcfg
> lrwxr-xr-x  1 root  wheel      15 Dec 26 08:40 /usr/local/bin/libpng-config -> libpng16-config
> -rwxr-xr-x  1 root  wheel    2320 Dec 26 08:39 /usr/local/bin/libpng16-config
> -r-xr-xr-x  1 root  wheel  356578 Dec 30 08:34 /usr/local/bin/libtool
> -rwxr-xr-x  1 root  wheel       0 Dec 30 08:34 /usr/local/bin/libtoolize
> -r-xr-xr-x  1 root  wheel    2485 Jul 16 00:48 /usr/local/bin/libwmf-config
> -r-xr-xr-x  1 root  wheel   13101 Jul 16 00:48 /usr/local/bin/libwmf-fontmap
> -r-xr-xr-x  1 root  wheel    1448 Jul 18 22:10 /usr/local/bin/libwww-config
> 
> So the scripts involved in building libva-1.5.0 found libtoolize but couldn't see if it was functional.
> 
> I wonder what happened, how /usr/local/bin/libtoolize was truncated.
> 
> So I guess that's why I got the message
> 
> configure.ac:166: error: required file './ltmain.sh' not found
> 
> Also, pkg gives no hint of files being corrupted.
> 
> I also ran, from /usr/ports directory,
> 
> tar tvf ../packages/All/libtool-2.4.2.418.txz
> 
> and /usr/local/bin/libtoolize showed as 0 bytes.
> 
> pkg-plist didn't show sizes of package files.

For some reason that package has a truncated file. It looks definitely
as a local problem on your system, if it was a general problems this
list would be flooded by problem reports about this by now.

You can mail a build log for devel/libtool to me and I can have a look
and see what's wrong. You should try having a look yourself first though.

You also have the option of grabbing the official package fro the
FreeBSD mirrors, which are not showing this problem.

> 
> I see libtool is now at v2.4.4. upstream (www.gnu.org/software/libtool) as of 29-Nov-2014.
> 
> I could try to rebuild devel/libtool, but that won't improve anything if the port or package is defective.
> 

As I said if the port was defective we would be getting floods of
reports about this by users, since this is not happening, the ports
build cluster is building it successfully and I have not been able to
reproduce the problem I guess it's a problem caused by something on your
system.

You should investigate why libtoolize is being created as an empty file.

The ports, for example, depends on gm4 from devel/m4, have you tried
also rebuilding that?

> I just tried, same result, no joy.

I can try to help you, but please move further followups to private mail
to me.

I could have a look at a build log for libtool from your system.

-- 
Guido Falsi <madpilot at FreeBSD.org>


More information about the freebsd-ports mailing list