ksh93: Exec format error

no@spam@mgEDV.net nospam at mgedv.net
Sat Jan 10 15:30:28 UTC 2015

ksh93 in it's current version has some (timing?) problems during execution.
i couldn't really nail down whats going on (and don't have the time now).
there is a known bug with the same error message from 2009 in the
ksh-changelogs, where they mention the timing problem to be fixed.
although everything seems to work fine, e.g. the following command
caused the error to happen very often:
pfctl -s Tables|while read x
echo $x
pfctl -t $x -T show
--> this is the error: pfctl: cannot execute [Exec format error]
when i run this command a few times again, the errors are shown for
any tables in the first command, and for different tables in the 2nd.
(no fw changes during commands and pf disabled).
i tried ksh from ports
as well as compiling my own (which really sucked) with INIT.2013-05-24.tgz,
ast-ksh.2012-08-01.tgz from AT&T.
both binaries produce the same error more or less randomly.
i used freebsd-10.1-REL and tried it with the stock and a custom kernel.
(ksh was recompiled both times, everything under AMD64 on VMWare 5.5).
the same errors happen, when compiling with INIT-2012-08-01. i used to have
my own compile env which does exactly the same for building ksh under 10.1,
as it did under freebsd-8.2-i386. but there i could build a static binary
with success.
this static ksh runs fine on the 10.1-amd64, too without the exec errors
i have no clue (besides the move from gcc->clang and some newer os-libs),
what could cause to almost break the ksh port, but anything happened to it.

More information about the freebsd-ports mailing list