upgrading texlive broken due to cmake

Will Parsons varro at nodomain.invalid
Wed Jan 7 20:41:11 UTC 2015

In attempting to update texlive, I ran into a problem that is
addressed by UPDATING note 20141214.  Following the note I ran:

  # pkg delete -f tex-kpathsea texlive-base

and then attempted to install the new versions using portmaster.

tex-kpathsea installed, but texlive-base didn't due to a failure to
build the cmake dependency:

===>  Patching for cmake-3.1.0
===>  Applying FreeBSD patches for cmake-3.1.0
/bin/rm -f /usr/ports/devel/cmake/work/cmake-3.1.0/Help/manual/cmake-gui.1.rst
===>   cmake-3.1.0 depends on executable: sphinx-build - not found
===>    Verifying install for sphinx-build in /usr/ports/textproc/py-sphinx
===>  Building for py27-sphinx-1.2.3
running build
running build_py
running egg_info
writing requirements to Sphinx.egg-info/requires.txt
writing Sphinx.egg-info/PKG-INFO
writing top-level names to Sphinx.egg-info/top_level.txt
writing dependency_links to Sphinx.egg-info/dependency_links.txt
writing entry points to Sphinx.egg-info/entry_points.txt
reading manifest file 'Sphinx.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
no previously-included directories found matching 'doc/_build'
writing manifest file 'Sphinx.egg-info/SOURCES.txt'
cd /usr/ports/textproc/py-sphinx/work/Sphinx-1.2.3/build/lib &&  /usr/bin/env PYTHONPATH=/usr/ports/textproc/py-sphinx/work/Sphinx-1.2.3/build/lib:/usr/local/lib/python2.7/site-packages  /usr/local/bin/python2.7 -m sphinx.pycode.pgen2.driver -c 'import load_grammar'
/usr/local/bin/python2.7: No module named jinja2
*** [post-build] Error code 1

Stop in /usr/ports/textproc/py-sphinx.
*** [build-depends] Error code 1

Stop in /usr/ports/devel/cmake.
*** [build] Error code 1

Stop in /usr/ports/devel/cmake.

===>>> make build failed for devel/cmake
===>>> Aborting update

===>>> Update for cmake-3.0.2 failed
===>>> Aborting update

===>>> Update for openjpeg15-1.5.2 failed
===>>> Aborting update

===>>> Update for tex-web2c-20140525 failed
===>>> Aborting update


I can't seem to find anything in UPDATING relevant.


More information about the freebsd-ports mailing list