Samba 4.2 crashes

Andrea Venturoli ml at
Tue Aug 25 16:03:05 UTC 2015


I'm trying to upgrade from samba 3.6 to 4.2 (mainly because the former 
is deprecated, so I don't want AD, just plain old functionality).

I started with simpler installations and had almost no problem.
However, in a just a little bit more complex case (PDC+BDC with LDAP 
backend), smbd and/or winbindd keep crashing.

I started by upgrading the PDC; everything should be fine (config files, 
rc.conf, database directory, connection to LDAP, etc...).
However I'm getting lots of the following messages:

> kernel: pid 50545 (smbd), uid 0: exited on signal 6

> winbindd[89801]: stack overflow detected; terminated

> winbindd[89801]: stack overflow detected; terminated

and basically nothing works.

The box is running 9.3/amd64 and I have "WITH_SSP_PORTS=yes" in 
So I removed that line and issued a "portupgrade -Rf samba42"; 
afterwards, however, samba failed in the same way.

Then I tried building samba in debug mode, with "env 

I get crash dumps, but trying to interpret them fails:
> cd /usr/ports/net/samba42/work/samba-4.2.3/bin/default/source3/winbindd/
> # gdb winbindd /winbindd.core
> GNU gdb 6.1.1 [FreeBSD]
> Copyright 2004 Free Software Foundation, Inc.
> GDB is free software, covered by the GNU General Public License, and you are
> welcome to change it and/or distribute copies of it under certain conditions.
> Type "show copying" to see the conditions.
> There is absolutely no warranty for GDB.  Type "show warranty" for details.
> This GDB was configured as "amd64-marcel-freebsd"...
> Core was generated by `winbindd'.
> Program terminated with signal 6, Aborted.
> #0  0x0000000808c8238c in ?? ()
> (gdb) bt
> #0  0x0000000808c8238c in ?? ()
> #1  0x0000000808c22dd6 in ?? ()
> #2  0x0000000000000000 in ?? ()
> (gdb) q

Even trying with gdb-7.9.1 from ports yields the same result.

Not even a simple debugging session works:
> # /usr/local/bin/gdb winbindd
> GNU gdb (GDB) 7.9.1 [GDB v7.9.1 for FreeBSD]
> Copyright (C) 2015 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
> and "show warranty" for details.
> This GDB was configured as "x86_64-portbld-freebsd9.3".
> Type "show configuration" for configuration details.
> For bug reporting instructions, please see:
> <>.
> Find the GDB manual and other documentation resources online at:
> <>.
> For help, type "help".
> Type "apropos word" to search for commands related to "word"...
> Reading symbols from winbindd...done.
> (gdb) b main
> Breakpoint 1 at 0x3c039: file ../source3/winbindd/winbindd.c, line 1428.
> (gdb) r
> Starting program: /usr/ports/net/samba42/work/samba-4.2.3/bin/default/source3/winbindd/winbindd
> Error in re-setting breakpoint 1: Cannot access memory at address 0x3c020
> Error in re-setting breakpoint 1: Cannot access memory at address 0x3c020
> [Inferior 1 (process 59552) exited normally]

So, any hint on what to do to sort this out?
How do I debug smbd and/or winbindd?

  bye & Thanks

P.S. I saw another thread suggesting 
"", but that doesn't 
seem to be my problem; I tried anyway, but without success.

P.P.S. Out of curiosity I also tried samba41 and samba4 and experienced 
similar behaviour.

More information about the freebsd-ports mailing list