portmaster doesn't fetch qt sources while simple "make install" does

Thomas Mueller mueller6724 at bellsouth.net
Tue Apr 28 18:01:01 UTC 2015

> while rebuilding krdc from ports I run into a problem that portmaster hangs when it tries to download the sourcefile:

=> qt-everywhere-opensource-src-4.8.6.tar.gz doesn't seem to exist in /usr/ports/distfiles//KDE.
=> Attempting to fetch http://download.qt-project.org/official_releases/qt/4.8/4.8.6//qt-everywhere-opensource-src-4.8.6.tar.gz

> Fetching the package with a  web browser or even just by doing a "make
> reinstall" does the download of the same source file.

> Was someone facing a similar behavior?

> Regards,

> Dominik

I had the problem of being unable to download the qt-everywhere source file on this computer, but it was a different cause probably relating to the rsu(4) driver for Hiro H50191 USB wireless adapter.

My solution was to either sneakernet from the other computer via USB stick or boot into NetBSD where the re(4) Ethernet driver works, download the file to distfiles directory with Lynx, and boot back to FreeBSD.

If I tried to download that file from FreeBSD, it would go partway, stall, and go back to the start, repeatedly.

I would have thought "make reinstall" or "make fetch" would use the same downloading mechanism used by portmaster, while a web browser might use a different protocol like http(s).


More information about the freebsd-ports mailing list