Error building net/asterisk

Guido Falsi madpilot at
Fri Apr 17 07:30:03 UTC 2015

On 04/17/15 02:05, Bob Eager wrote:
> I've previously built this port (as version with no problems
> under 9.1.
> I'm now upgrading to 10.1 and tried to rebuild (with an updated ports
> tree from about four days ago, so using 1.8.32_3 now).

Port is at now, can you confirm you're using this version?

revision 383864 of the port Makefile.

> A couple of files fail to link - main/asterisk.c and main/pbx.c. They
> are wanting libsysinfo. 
> I can see nowhere that calls for libsysinfo in the Makefile in main/,
> yet it built OK on 9.1!
> I fixed it by adding -lsysinfo to AST_LIBS in main/Makefile, but wonder
> if there is some more important underlying issue.


I have never seen this issue when testing the port. In fact I don't have
the devel/sysinfo port installed on machines I run asterisk on. So I
think it's something with your environment which is triggering the
problem. I need some further information to investigate this and
understand if it needs some modification to the port.

Are you using default options? was the devel/sysinfo port already
present on the system?

If possible could you send me the failed build log and also the
config.log file from the ports workdir?


Guido Falsi <madpilot at>

More information about the freebsd-ports mailing list