databases/mysql-connector-java: Looks broken to me

Mikhail T. mi+thun at aldan.algebra.com
Tue Apr 7 21:53:23 UTC 2015


On 07.04.2015 02:41, Matthew Seaman wrote:
> So anyone using JDBC3 would be disappointed by our chopping it out.  I
> have precisely zero idea how many people that might be, or indeed how
> much call there is for JDBC3 adaptors in general.
If the difference between JDBC3 and 4 is the compiler-version used to compile
them, then JDBC3 must only be of interest to those, who still use Java-1.5 for
whatever reason. These would not be new FreeBSD installations...

Various other packages have stopped supporting JDBC3 long ago
<https://www.google.com/search?q=JDBC3+obsolete>. I'd recommend dropping it too.

But if you think, we should not drop it, there is still no need for the older
JDKs. Any newer javac can be asked to generate older bytecode. For example:

    javac -source 1.5 -target 1.5 ...

Yours,

    -mi



More information about the freebsd-ports mailing list