FreeBSD Port: devel/tortoisehg - is not compatible with Mercurial version 3.1

arrowdodger 6yearold at gmail.com
Sun Sep 21 09:34:47 UTC 2014


On Fri, Sep 19, 2014 at 2:10 PM, Miroslav Lachman <000.fbsd at quip.cz> wrote:

> Hi,
> I tried to install TortoiseHG on FreeBSD 10 (PC-BSD), but it doesn't work,
> because it is not compatible with Mercurial 3.1.1 (version in ports tree).
>
> It just shows this error:
>
> Bug Report from TortoiseHG follows:
>
> #!python
>
>  * Mercurial version (3.1). TortoiseHg version (3.0.1)
>  * Command:
>  * CWD: /usr/home/XXXX
>  * Encoding: UTF-8
>  * Extensions loaded:
>  * Python version: 2.7.8 (default, Aug 27 2014, 21:13:20) [GCC 4.2.1
>    Compatible FreeBSD Clang 3.3 (tags/RELEASE_33/final 183502)]
>  * System: FreeBSD yyyyyyy.XXXX.test 10.0-RELEASE-p15 FreeBSD
>    10.0-RELEASE-p15 #0: Wed Jul 9 15:46:53 UTC 2014
>    root at amd64-builder.pcbsd.org
>    <mailto:root at amd64-builder.pcbsd.org>:/usr/obj/usr/src/sys/GENERIC
> amd64
>  * Qt-4.8.6 PyQt-4.11.1 QScintilla-2.8.3
>
> |This version of TortoiseHg requires Mercurial version 2.9.n to 3.0.n, but
> found 3.1
>
>
> Can you please update TortoiseHG to more current version?
>
> The website http://tortoisehg.bitbucket.org/ has:
> |
>
>  * 2014-09-04: TortoiseHg 3.1.1 (with Mercurial 3.1.1) released
>  * 2014-08-03: TortoiseHg 3.1 (with Mercurial 3.1+2) released
>
>
> Miroslav Lachman
>
>
Oh, right. I've got taken away by $WORK.
Will update the port ASAP.


More information about the freebsd-ports mailing list