Unable to upgrade tex-xetex and tex-luatex: libpoppler.so.44 not found

Dr. Peter Voigt pvoigt at uos.de
Tue Nov 25 18:53:57 UTC 2014


On Tue, 25 Nov 2014 19:41:51 +0100
Marcus von Appen <mva at FreeBSD.org> wrote:

> On, Tue Nov 25, 2014, Dr. Peter Voigt wrote:
> 
> > I am currently unable to upgrade tex-xetex and tex-luatex on
> > 10.1-RELEASE (amd64).
> >
> [...]
> 
> > ' ... Shared object "libpoppler.so.44" not found, required by
> > "xetex" Error: `xetex -ini  -jobname=xetex -progname=xetex -etex
> > xetex.ini ' failed
> >
> > ###############################################################################
> > fmtutil: Error! Not all formats have been built successfully.
> > Visit the log files in directory
> >   /usr/ports/print/tex-xetex/work/stage/usr/local/share/texmf-var/web2c
> > for details.
> > ###############################################################################
> >
> > This is a summary of all `failed' messages:
> > `xetex -ini  -jobname=xetex -progname=xetex -etex xetex.ini ' failed
> > *** Error code 1
> >
> 
> The tex-xetex and tex-luatex ports use the first `xetex` or `luatex`
> that is found in your PATH environment, thus the build process uses
> the old (outdated) versions in /usr/local/bin. You can work around
> this by deinstalling both first, and then install them.
> 
> Cheers
> Marcus

Thank you both for your quick replies. Your solution worked for me.

Regards,
Peter
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20141125/40b71c42/attachment.sig>


More information about the freebsd-ports mailing list