rawrec fail - 10.1 breakage?

Konstantin Belousov kostikbel at gmail.com
Fri Nov 21 17:35:53 UTC 2014

On Fri, Nov 21, 2014 at 08:46:47AM -0800, Jeff Anton wrote:
> I've been using the rawrec port and after the 10.1 upgrade it no longer 
> works.
> atlas.hesiod.org:anton[42]: rawrec
> (null): sigaction on SIGIO failed: Invalid argument
> I reinstalled with pkg install -f rawrec and built from the port and 
> still get the problem.
> 10.0 worked ok, but 10.1 is failing.
> I don't have time to debug in detail right now, but this kind of failure 
> feels like an ABI breakage to me.  Other audio applications such as xmms 
> and mixer are working so it doesn't seem like a driver problem.
> Any clues?

I cannot provide you with clue without the problem being debugged.

A voice near me says that it could be due to uninitialized struct
sigaction' sa_flags. Before 10.1, unused bits in sa_flags where silently
ignored, while 10.1 started checking. If this is true, the program
triggered undefined behaviour, which is catched now.

More information about the freebsd-ports mailing list