FreeBSD Port: cfengine36-3.6.1_3,1

Steven Kreuzer skreuzer at freebsd.org
Tue Nov 18 23:00:17 UTC 2014


Hi Jurica-

On Mon, Nov 17, 2014 at 12:18 PM, Jurica Borozan
<jurica.borozan at gmail.com> wrote:
> Hi,
>
> I am trying to run cfengine 3.6.1 and 3.5.8 but it will not work with
> XML files: "error: Cannot edit XML files without LIBXML2"

It looks like the current version of the port doesn't have the option
to pull in libxml2 to enable this feature.
Can you try out this patch and let me know if it solves your issue?
https://people.freebsd.org/~skreuzer/patches/cfengine36-libxml.patch

The following commands will download the patch into your home
directory, apply the changes to the port and build and install a
version of
cfengine with xml support

$ cd ~
$ fetch https://people.freebsd.org/~skreuzer/patches/cfengine36-libxml.patch
$ cd /usr/ports
$ patch < ~/cfengine36-libxml.patch
$ cd /usr/ports/sysutils/cfengine36
$ sudo make WITH="LIBXML2" install

Let me know if you have any problems.

Thanks


More information about the freebsd-ports mailing list