net/linphone-base failed compiling

Muhammad Moinur Rahman 5u623l20 at gmail.com
Mon May 26 20:30:35 UTC 2014


Hi,
linphone-base won't compile with libexosip2 anymore. The dependency have
been changed to libexosip2-legacy. This has been done to update to the
latest libexosip2 code. And hence you will need libosip not libosip2.

Happy porting.
Muhammad


On Tue, May 27, 2014 at 1:46 AM, Dr. Peter Voigt <pvoigt at uos.de> wrote:

> Am Mon, 26 May 2014 15:12:14 -0400
> schrieb Ajtim <lumiwa at gmail.com>:
>
> > On Monday 26 May 2014 13:41:52 neel at neelc.org wrote:
> >
> > pkg delete -f net/libexosip2 ne/libosip2
> >
>
> Hm, I am having the same issue. Forced deletion of net/libexosip2
> ne/libosip2 is just neccessary to upgrade both ports. The command should
> have gone to /usr/ports/UPDATING. But on my system with 10.0-RELEASE-p3
> net/linphone stills fails:
>
> # pkg version -vIL=
> linphone-base-3.2.1_2,1            <   needs updating (index has
> 3.2.1_3,1)
>
> # pkg version -v |grep osip2libeXosip2-4.1.0
> libeXosip2-4.1.0                   =   up-to-date with port
> libosip2-4.1.0                     =   up-to-date with port
>
> # portmaster --no-confirm --no-term-title -D -G linphone-base
> ...
> fatal error: too many errors emitted, stopping now
> [-ferror-limit=] 20 errors generated.
> gmake[3]: *** [linphonecore.lo] Fehler 1
> mv -f .deps/enum.Tpo .deps/enum.Plo
> libtool: compile:  cc -DHAVE_CONFIG_H -I. -I.. -I..
> -I../mediastreamer2/include -I/usr/local/include -DIN_LINPHONE
> -I/usr/local/include -I/usr/local/include -DOSIP_MT -I../oRTP/include
> -DENABLE_TRACE -DLOG_DOMAIN=\"LinphoneCore\" -DORTP_INET6 -O2 -pipe
> -fno-strict-aliasing -MT misc.lo -MD -MP -MF .deps/misc.Tpo -c misc.c
> -o misc.o >/dev/null 2>&1 mv -f .deps/misc.Tpo .deps/misc.Plo gmake[3]:
> Leaving directory
> `/usr/ports/net/linphone-base/work/linphone-3.2.1/coreapi' gmake[2]:
> *** [all-recursive] Fehler 1 gmake[2]: Leaving directory
> `/usr/ports/net/linphone-base/work/linphone-3.2.1' gmake[1]: *** [all]
> Fehler 2 gmake[1]: Leaving directory
> `/usr/ports/net/linphone-base/work/linphone-3.2.1' ===> Compilation
> failed unexpectedly. Try to set MAKE_JOBS_UNSAFE=yes and rebuild before
> reporting the failure to the maintainer. *** Error code 1
>
> Stop.
> make: stopped in /usr/ports/net/linphone-base
>
> ===>>> make failed for net/linphone-base
> ===>>> Aborting update
>
>
> ===>>> You can restart from the point of failure with this command line:
>        portmaster <flags> net/linphone-base
>
> Regards,
> Peter
> _______________________________________________
> freebsd-ports at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-ports
> To unsubscribe, send any mail to "freebsd-ports-unsubscribe at freebsd.org"
>


More information about the freebsd-ports mailing list