math/sage error log message

Bruce bruce at hawaii-pacific.com
Wed May 14 19:36:36 UTC 2014


At this time I get the same error at the same place.  I have had sage on 
this computer before freebsd-9.2 and haven't been able to build it 
since.  Every time I notice a change in the sage port I try again.  I 
have tried about 4 times in the last week.  Before the last Makefile 
change in the port it got a lot farther and the error was during the 
building of the html documentation.
I have tried MAKE_JOBS_UNSAFE and it gets farther.

I am using a Shuttle xpc with amd 64 and freebsd-9.2

uname -a FreeBSD 192.168.1.4 9.2-RELEASE FreeBSD 9.2-RELEASE #0 r255898: 
Thu Sep 26 22:50:31 UTC 2013 
root at bake.isc.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

Thanks for your help.

Montgomery-Smith, Stephen wrote:
> On 05/13/2014 07:17 PM, Bruce wrote:
>
>> -Wl,-rpath=/usr/local/lib/gcc47 -g -fPIC -c linbox-sage.C  -fPIC -DPIC
>> -o .libs/linbox-sage.o
>> {standard input}: Assembler messages:
>> {standard input}:669830: Warning: end of file not at end of a line;
>> newline inserted
>> {standard input}:670930: Error: unknown pseudo-op: `.lvl719'
>> {standard input}: Error: open CFI at the end of file; missing
>> .cfi_endproc directive
>> g++47: internal compiler error: Killed: 9 (program cc1plus)
>> Please submit a full bug report,
>> with preprocessed source if appropriate.
>> .............
> What a horrible error!  Do you get the error in the same place every
> time you try to compile sage?
>
> It might be a hardware error, or maybe the compiler is running out of
> memory.  Did you try building it with MAKE_JOBS_UNSAFE set?  How many
> cores do you have on your processor?
> _______________________________________________
> freebsd-ports at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-ports
> To unsubscribe, send any mail to "freebsd-ports-unsubscribe at freebsd.org"
>



More information about the freebsd-ports mailing list