devel/doxygen: Need TeX help

Naram Qashat cyberbotx at
Mon May 12 00:34:34 UTC 2014

On 03/18/14 18:32, Naram Qashat wrote:
> On 03/18/14 11:56, A.J. 'Fonz' van Werven wrote:
>> Naram Qashat wrote:
>>>>> I basically get the following when it comes up to ./langhowto.tex:
>>>>> ! LaTeX Error: Environment longtable undefined.
>> [snip]
>>>> It's probably not as simple as this, but I'll ask anyway: have you
>>>> tried the following?
>>>> # texconfig-sys rehash
>>> I hadn't tried that, but I did that just now and I still get the same
>>> error.
>>> Would've been nice if it had been that simple. :P
>> Bummer, sorry it didn't help. However, as you may have noticed I quoted
>> your entire message in my first reply and CC'ed it to the freebsd-tex@
>> mailing list. So hopefully someone on either list (the other being
>> freebsd-ports@) knows what else to try.
>> Furthermore: are you getting this error during building or during use? I
>> tried building devel/doxygen with PDF support and it built perfectly fine
>> here.
>> AvW
> It was during building. The port is currently at, and I actually ran
> into the problem in the email when I initially was trying to update to 1.8.4.
> That was the main reason I haven't pushed out an update to the port yet.
> Oddly enough, when I try to build on my machine currently, I also get a
> TeX error, but an entirely different one. I can't recall what the error was, but
> it had nothing to do with longtable.
> Thanks,
> Naram Qashat

I'm going to try bringing this back up, since it has been a bit over a month 
now. Doxygen updated to 1.8.7, so I went back to trying to update the port. Now, 
I am getting two different stopping points with TeX depending on if I use teTeX 
or TeXLive.

If I use teTeX, then I get the following error:

! Package keyval Error: pdfencoding undefined.

I'm not exactly sure what part of the manual is causing this, but it seems to 
happen pretty quickly upon starting the PDF creation process.

If I use TeXLive, though, it gets past that point and then ends up with the same 
error as I was getting with 1.8.6, with the longtable error shown earlier in 
this thread.

Because I wasn't sure if something in my own system's environment was the issue, 
I built the ports using Tinderbox and Poudriere in a virtual machine. So 
apparently it isn't an issue with my system, as a pristine and jailed system has 
the same issue. Both my system as well as the one in the VM are 9-STABLE, since 
I think I did forget to mention that earlier in the thread (oops).

One thing, though, about the keyval error, someone reported it on a mailing 
list, but there was no reply. It appears to have come about since 1.8.7 got 

I really would appreciate some insight on this, though. I know nothing about TeX 
and these errors just keep making the doxygen port get more and more outdated.

Naram Qashat

More information about the freebsd-ports mailing list