devel/binutils and devel/gnulibiberty version mismatch

Geoff Speicher geoff at sea-incorporated.com
Wed May 7 17:01:07 UTC 2014


On Wed, May 7, 2014 at 12:05 PM, Geoff Speicher
<geoff at sea-incorporated.com>wrote:

> devel/binutils is at version 2.24, and as of 16-Dec-2013 no longer
> installs libiberty [1], but does install libbfd, which gets linked against
> the copy of libiberty (v2.24) in the build tree.
>
> To link an application against libbfd from devel/binutils, one must
> install devel/gnulibiberty to resolve the missing symbols, but that port
> uses libiberty from binutils v2.19.1 which doesn't contain all the symbols
> from v2.24 (e.g. filename_ncmp at a minimum).
>
> There is a separate devel/libbfd port that matches the version in
> devel/gnulibiberty but if your port requires ${LOCALBASE}/libbfd.a and
> devel/gnulibiberty as build dependencies, and you already have
> devel/binutils installed, then your port will fail when linking.
>
> Should I just mark the port as conflicting with devel/binutils or is there
> a better workaround for this?
>
> [1] http://svnweb.freebsd.org/ports?view=revision&revision=336642
>

Sorry for responding to myself, but it gets worse: the port I'm working on
requires gcc from ports (at least on FreeBSD 8.4, because it needs a c++11
compiler), which depends on devel/binutils, so I can't conflict with
binutils or else I don't have a compiler.

Is there any reason why devel/libbfd and devel/gnulibiberty shouldn't be
upgraded to v2.24?


More information about the freebsd-ports mailing list