guile broken for me on 11.0-CURRENT i386

Koop Mast kwm at
Sat Mar 29 11:47:33 UTC 2014

On 29-3-2014 12:38, Dimitry Andric wrote:
> On 03 Mar 2014, at 20:23, Don Lewis <truckman at> wrote:
>> I've been having trouble building gnome-games for a while now and
>> finally had some time to dig into it.  The problem appears to be that
>> guile is broken.  The gnome-games build runs guile-config during
>> configure doesn't notice that the output is messed up, which causes
>> breakage later in the build.
>> If I run guile-config, I get:
>> % guile-config
>> ERROR: Unbound variable: define
>> If I rebuild guile, cd to the work directory and run check-guile:
>> # ./check-guile
>> Testing /usr/ports/lang/guile/work/guile-1.8.8/pre-inst-guile ...
>> with GUILE_LOAD_PATH=/usr/ports/lang/guile/work/guile-1.8.8/test-suite
>> ERROR: Unbound variable: define
>> I tried rebuilding with gcc46 instead of clang, but that doesn't make
>> any difference.  I don't see any suspicious compilation warnings.
>> Is anyone else seeing this?
> Yep, I've banged my head against this for a few days, and gave up
> eventually.  It is screwing up some sort of internal state; compiling
> with clang or gcc makes no difference.
> Also, upstream seems to have abandoned 1.8, and recommends 2.0.  I'd say
> just dump this version, and attempt to upgrade...
> -Dimitry

Zachary Storer spend a lot of time with upstream on getting guile 2.0 
working on FreeBSD (and squashing some other bugs on the way). He and I 
are just working out some details before we going to commit it to ports. 
We planning on making lang/guile2 and after wards looking into if it is 
possible to port all the guile users over.


More information about the freebsd-ports mailing list