Unable to install "Textproc/docbook-xml"

Jerry jerry at seibercom.net
Sat Mar 29 11:22:55 UTC 2014

On March 29, 2014 6:52 AM, Chris Rees replied:
> On , Jerry wrote:
> > On: Saturday, March 29, 2014 12:41 AM, Kevin Oberman replied:
> > On Fri, Mar 28, 2014 at 7:06 AM, Jerry  wrote:
> >
> > FreeBSD-10.0 amd64
> >
> > I have been unable to get the “textproc/docbook-xml” to install. I
> > followed the directions in “UPDATING”; however, that did not seem to
> > make a difference. This is the build log for the port.


> > Did you follow all of the instructions in UPDATING  20140219?
> >
> > Did you read the second sentence of my original post?
> I think the instructions are incomplete.  You also need to run pkg delete -f
> docbook.
> Please let me know if that's fixed it, and we can get the note fixed.
> Chris

That worked sort of. I found out I still had to run: "pkg delete -f docbook-sgml\*" even after running " pkg delete -f docbook-xml\* docbook-sk\* docbook\[2345\]\?\?-\* docbook-4\*" or else I received the following error message:

===>  Installing for docbook-xml-5.0_1
===>   Registering installation for docbook-xml-5.0_1
xmlcatmgr: entry already exists for `/usr/local/share/xml/docbook/catalog.xml' of type `nextCatalog'
xmlcatmgr: entry already exists for `/usr/local/share/xml/docbook/catalog' of type `CATALOG'
pkg-static: POST-INSTALL script failed
Installing docbook-xml-5.0_1... done

Anyway, after I nuked every last bit of that crap, I got it all to install correctly. Seriously though, I have better things to do with my time. Thanks for your assistance. You might want to add a note to updating regarding this problem.


More information about the freebsd-ports mailing list