samba-4.1.6 FreeBSD 10 cannot read from share.

Timur I. Bakeyev timur at
Wed Mar 26 10:56:42 UTC 2014

Hi, Johan!

On Wed, Mar 26, 2014 at 10:42 AM, Johan Hendriks <joh.hendriks at>wrote:

> Hello all.
> I am using samba 3.x.x for a long time to share files across the network
> as a domain member server.
> All is working like it should. Lately i tried the samba 41 port and
> package to do the same job.
> However I am not able to get it working.
> Everything seems to work, i can browse the share, i can write to the share
> and i can delete files from the share. But as soon as I want to read from
> the share windows explorer hangs. wbinfo -u works, id <user> works. I have
> rebuild samba41, i installed a new FreeBSD 10 machine and installed
> samba41, I also tried the package of samba but the issue remains. Also i
> tried to trim down the smb4.conf file.
> The error i get is this (translated from dutch)
> There is a problem accessing the file I:\data\filetocopy
> Make sure your computer is connected to the network and try again.
> In my logs i do not see a lot of strange things , i do see this....
> Mar 25 15:47:50 freetest smbd[80071]: [2014/03/25 15:47:50.679688, 0,
> pid=80071, effective(0, 10004), real(0, 0)] ../source3/smbd/reply.c:3079(
> fake_sendfile)
> Mar 25 15:47:50 freetest smbd[80071]: [2014/03/25 15:47:50.680200, 0,
> pid=80071, effective(0, 10004), real(0, 0)] ../source3/smbd/smb2_read.c:
> 235(smb2_sendfile_send_data)
> Mar 25 15:47:50 freetest smbd[80071]:   smb2_sendfile_send_data:
> fake_sendfile failed for file ubcd526.iso (Socket is not connected).
> Terminating
> Could someone point me in the right direction, i have no idea how to
> overcome this.
> If i revert back to 3.6.xx all is fine.
Can't tell you much, but that 'fake_sendfile' looks weird, we do have real
one. Can you send be the config.log file?


More information about the freebsd-ports mailing list