reason 23 why we've moved to linux

Matthias Andree matthias.andree at gmx.de
Sun Mar 23 10:37:22 UTC 2014


Am 23.03.2014 01:18, schrieb Matthew Seaman:

> PACKAGESITE support in pkg.conf has been dropped entirely in 1.3 which
> is in alpha at the moment.  I need to double check, but that should mean
> those error messages will go away too.

To be blunt, anyone who wants to use FreeBSD for production does not
give a shit on pkg alpha versions, he expects pkg 1.0.0 or 1.0.1 at the
latest to cover 99% right.

I still foster that feeling that we are rushing and forcing ports
changes, including pkgNG transition, at a hilarious pace, and even if
portmgr states that -exp runs do happen for most changes, -exp runs will
not capture real-world systems that need to make several transitions
(pkgNG, USES=... transition of the day, Perl version of the day, Python
wrapper of the day, c++ lib of the version) at once.

And the lack of compatibility I've seen so far is frightening.  Most
people no longer test ports on pre-pkgNG systems because that's
deprecated.  But it needs to work fine until the day after expiration.


More information about the freebsd-ports mailing list