Net::DNS 0.77 / resolv.conf with comments (was: FreeBSD Port: spamassassin-3.4.0_11)

Michael Grimm trashcan at
Sat Jun 28 13:50:41 UTC 2014

On 25.06.2014, at 17:21, Michael Grimm <trashcan at> wrote:
> On 24.06.2014, at 12:57, Dirk-Willem van Gulik <dirkx at> wrote:
>> Op 24 jun. 2014, om 12:07 heeft Kurt Jaeger <lists at> het volgende geschreven:

>>> If you still see the problem, can you provide more details ?
>>> What did you test ? What was the output ?
>> The symptom is all DNS failing within Spam Assassin in the default FreeBSD 10-p3 with latest packages situations; logs will show:
>> 	Jun 24 12:02:04 weser spamd[78829]: plugin: eval failed: available_nameservers: No DNS servers available! 
>> 	Jun 24 12:02:04 weser spamd[78829]:  (available_nameservers: [...] No DNS servers available!) 
>> and the solution is to apply the patch from above SA link (below) -OR- go to a version from >= revision 1603518; for which 
>> there is not yet a release/tag (
> I ran into the same issue (10-STABLE, recent ports), and JFTR: I had to downgrade p5-Net-DNS-0.77 back to p5-Net-DNS-0.76 to get spamassassin-3.4.0_11 running again, no patches applied.

> spamassassin-3.4.0

spamassassin-3.4.0_11 and p5-Net-DNS-0.76 worked as expected. After upgrading to p5-Net-DNS-0.77 I ran into an issue that looked similar to the one reported above. spamd couldn't be daemonized at start-up (timed out). After some investigations I found the reason why spamd didn't start after upgrading to p5-Net-DNS-0.77:

	nameserver		# some comment
	nameserver		# another comment

That has been accepted by p5-Net-DNS-0.76, but for p5-Net-DNS-0.77 I had to remove the comments:


After removing those comments spamassassin-3.4.0_11 and p5-Net-DNS-0.77 run as expected.

Is this a bug or a feature?

Thanks and regards,

More information about the freebsd-ports mailing list