Sage update

Montgomery-Smith, Stephen stephen at
Fri Jan 31 00:07:58 UTC 2014

On 01/30/2014 05:32 PM, Ajtim wrote:

> I am not lucky:
> Now installing the Maxima library as '/usr/ports/math/sage/work/sage-6.0/local/lib/ecl//maxima.fas'...
> New ASDF encountered
> real    6m29.758s
> user    5m28.766s
> sys     0m28.508s
> Successfully installed maxima-5.29.1.p4
> Deleting temporary build directory
> /usr/ports/math/sage/work/sage-6.0/local/var/tmp/sage/build/maxima-5.29.1.p4
> Finished installing maxima-5.29.1.p4.spkg
> make[4]: Leaving directory `/usr/ports/math/sage/work/sage-6.0/build'
> make[3]: *** [all] Error 2
> make[3]: Leaving directory `/usr/ports/math/sage/work/sage-6.0/build'
> real    18m28.872s
> user    94m55.810s
> sys     7m31.317s
> ***************************************************************
> Error building Sage.
> The following package(s) may have failed to build:
> package: r-3.0.2.p0
> log file: /usr/ports/math/sage/work/sage-6.0/logs/pkgs/r-3.0.2.p0.log
> build directory: /usr/ports/math/sage/work/sage-6.0/local/var/tmp/sage/build/r-3.0.2.p0
> The build directory may contain configuration files and other potentially
> helpful information. WARNING: if you now run 'make' again, the build
> directory will, by default, be deleted. Set the environment variable
> SAGE_KEEP_BUILT_SPKGS to 'yes' to prevent this.
> gmake[2]: *** [build] Error 1
> gmake[2]: Leaving directory `/usr/ports/math/sage/work/sage-6.0'
> ===> Compilation failed unexpectedly.
> Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
> the maintainer.
> *** Error code 1
> Stop.
> make[1]: stopped in /usr/ports/math/sage
> *** Error code 1
> Stop.
> make: stopped in /usr/ports/math/sage

Can you send me this file:

Because the build is multithreaded, the install.log gets different
builds mixed up, and the error that caused the problem isn't always in
the last few lines.

However, I am also getting a build error at r-3.0.2.p0, and it is
exactly the same error as I was getting before.  All I want to check is
whether you are getting the same error as me.

I am also getting a build error with scipy and matplotlib-1.2.1.  The
scipy error exactly matches an error message I received from one of you
earlier today (before I applied the fix).

This means that whatever the problem is, the fix didn't fix it.

More information about the freebsd-ports mailing list