Error compiling ports on FreeBSD 10 for ARM (Raspberry Pi)

Stephen Forsyth mr.f at
Wed Jan 29 00:07:53 UTC 2014

Hi Ports subscribers,

I've been trying out a recent build of what may become the FreeBSD 10.0 
release for ARM ("FreeBSD 10.0-RELEASE (RPI-B) #0 r261135"). There 
aren't any non-x86 pkg builds available yet, so I used portsnap to 
install ports.

All the ports I have tried to install (tmux, curl, pkg, sudo) fail with 
the same error:

   /usr/lib/libcrypto.a(pmeth_lib.o):(.data+0x0): undefined reference to 
   cc: error: linker command failed with exit code 1 (use -v to see 
   *** [pkg-static] Error code 1

For example, if I go to /usr/ports/sysutils/tmux and run "make install" 
as root, and fifteen minutes later the build fails with this error.

Does anyone know how what the cause of an issue like this might be? I'm 
relatively new to FreeBSD, so I'm out of my depth when it comes to 
compile issues on a new architecture. Searches for rsa_pkey_meth linker 
errors using a popular web search engine didn't yield anything that 
looked useful. Are packages being signed after they are built?

Thank-you in advance for any thoughts or insights that you may have,


More information about the freebsd-ports mailing list