VirtualBox 4.3.6 + FreeBSD 10 + clang, [SUCCESS]

Craig Rodrigues rodrigc at
Mon Jan 13 06:46:40 UTC 2014

On Sun, Jan 12, 2014 at 5:36 PM, Miguel Clara <miguelmclara at>wrote:

> I tried this approach and still get errors:
> ********************
> kmk: ***
> [/tmp/tmp/xy/jkim/emulators/virtualbox-ose/work/VirtualBox-4.3.6/out/freebsd.amd64/release/obj/VBoxSVC/src-server/ApplianceImpl.o]

I tried the following on a second machine running 10.0-RC5 and it worked
for me so you might want to try.

(1)  Delete some ports before starting:

pkg delete virtualbox-ose
pkg delete virtualbox-ose-kmod
pkg delete gsoap

(2)  Make sure ports tree is updated:

portsnap fetch
portsnap extract

(3)  Remove a few directories:

rm -fr /usr/ports/devel/gsoap
rm -fr /usr/ports/emulators/virtualbox-ose*

(4)  Check out jkim's tree from redports:

mkdir -p /tmp/xy
cd /tmp/xy
svn co

(5)  Copy a few of jkim's ports into port tree:

(cd /tmp/xy/jkim/emulators && tar -c -v -f - . )  | ( cd
/usr/ports/emulators && tar -x -v -f - )
mkdir -p /usr/ports/devel/gsoap
(cd /tmp/xy/jkim/devel/gsoap && tar -c -v -f - . )  | ( cd
/usr/ports/devel/gsoap && tar -x -v -f - )

(6)  Build:

cd /usr/ports/devel/gsoap
make install
cd /usr/ports/emulators/virtualbox-ose-kmod
make install
make install

As Bernard mentioned, give a pointer to the full build log if there is an
error, not just an extract of the error message.


More information about the freebsd-ports mailing list