how to install ruby18

Steve Wills swills at freebsd.org
Sat Jan 4 20:49:47 UTC 2014


On Sat, Jan 04, 2014 at 03:45:12PM +0100, John Marino wrote:
> On 1/4/2014 15:38, Marco Beishuizen wrote:
> > On Sat, 4 Jan 2014, the wise John Marino wrote:
> > 
> > Portupgrade builds fine, but I have my locale set to UTF-8 and in that
> > case the pkgdb breaks and portupgrade no longer works:
> > 
> > ...
> > root at yokozuna:/home/marco# pkgdb -FfO
> > --->  Checking the package registry database
> > invalid byte sequence in UTF-8
> > ...
> > 
> > When the locale is set to the standard C the error changes to "invalid
> > byte sequence in US-ASCII".
> > 
> > I have this error for a very long time and after a lot of searching and
> > fiddling with the locale settings have no idea how to solve this.
> > 
> > Ruby18 worked fine so that would be the best option imo.
> 
> Ruby18 is gone forever, and unsupported, so that's not the best option.
> DragonFly had these same type errors with ruby19, until we redefined
> GEM_ENV in bsd.ruby.mk
> 
> -GEM_ENV?=                LC_CTYPE=UTF-8
> +GEM_ENV+=                LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8
> 
> Maybe setting GEM_ENV in your make.conf and rebuilding all the ruby
> stuff would fix it for you too.  Shot in the dark.

I'm not sure this is the right solution. Most of those types of problems have
disappeared now that rdoc isn't a dependency. If you remove rubygem-rdoc, does
the problem go away?

Steve


More information about the freebsd-ports mailing list