Update gcc?

LuKreme kremels at kreme.com
Tue Feb 25 09:57:28 UTC 2014


At the risk of starting a kerfuffle, is there any reason to update gcc on 8.4 or 9.2 from the GPLv2 version 4.2.1 to something more current?

(I can think of many reasons *not* to, but they all have to do with writing code which I am not doing).

I know 10.0 moves to clang (which is familiar to me since OS X changed to clang a while ago because of the GPLv3 issues), but I'm not ready to move to 10.0 and I know there are still issues with clang and that some packages still require gcc.

-- 
The only reason for walking into the jaws of Death is so's you can steal
His gold teeth. --Colour of Magic



More information about the freebsd-ports mailing list