docbook updates fiasco continues...

Dr. Peter Voigt pvoigt at
Thu Feb 20 12:20:29 UTC 2014

Am Thu, 20 Feb 2014 12:05:07 +0100
schrieb kaltheat <kaltheat at>:

> Hi,
> just for the records:
> The instructions in UPDATING did not work for me in tcsh (which is
> standard shell in FreeBSD as far as I know). I had to switch to bourne
> shell (/bin/sh) to pkg delete docbook-ports.
> Regards,
> kaltheat
> _______________________________________________
> freebsd-ports at mailing list
> To unsubscribe, send any mail to
> "freebsd-ports-unsubscribe at"

Well, as allway I tried to upgrade without reading /usr/ports/UPDATING
before -). I usually go there only, if something goes wrong.

But this time, I did not even read UPDATING though I suddenly found
that the old docbook packages where still shown with "pkg version" but
where no longer installed: They have been marked as "orphaned
packages". At the same time I found missing dependencies. I manually
deinstalled the orphaned packages and installed the new docbook packages
and have run into next problems because docbook-utils could not be

And all the above problems occured right after having had trouble
because KDE could not be upgraded due to an error in docbook-xml.

Well, all together a lot of trouble with docbook packages. But now all
docbook related problems are solved and all packages are up to date
without portmaster/pkg detecting any dependency errors.

By the way: I am running FreeBSD 10.0-RELEASE with Bash as login shell
for root.


More information about the freebsd-ports mailing list