pidgin with pidgin-sipe plugin now aborts on connect

Janky Jay, III jankyj at unfs.us
Fri Feb 14 21:16:46 UTC 2014


Hello Greg,

	Simply editing the Makefile and the distinfo file inside the 
net-im/pidgin-sipe directory worked fine for me. I did the following:

1) Edit Makefile
   a) Changed PORTVERSION from 1.13.1 to 1.18.0
   b) Removed the PORTREVISION line

2) After editing the Makefile, I ran
   a) make makesum (to update the distinfo file)
   b) make all install clean

	Pidgin now connects without any issues using the Office Communicator 
protocol. I've also attached a patch for the port if you'd rather use 
that. If it works for you, I'll submit the patch to PR. Just let me know.

Regards,
Janky Jay, III

On 02/14/2014 11:00 AM, Greg Rivers wrote:
> Since the recent update of pidgin to version 2.10.9, pidgin aborts
> (signal 6) whenever I connect to a Office Communicator account via the
> pidgin-sipe plugin.  The pidgin-sipe port is very much out of date, so I
> suspect that pidgin has diverged enough to cause this.
>
> Are there any plans to bring the pidgin-sipe plugin up to date?
>

-------------- next part --------------
A non-text attachment was scrubbed...
Name: pidgin-sipe_1.18.0.diff
Type: text/x-patch
Size: 927 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20140214/165d746e/attachment.bin>


More information about the freebsd-ports mailing list