mediatomb

jcv jv at yeaguy.com
Wed Feb 12 01:36:19 UTC 2014



On Tue, 11 Feb 2014, Kevin Oberman wrote:

> On Tue, Feb 11, 2014 at 2:55 PM, jcv <jv at yeaguy.com> wrote:
>
>>
>>
>> On Tue, 11 Feb 2014, Kevin Oberman wrote:
>>
>>  On Tue, Feb 11, 2014 at 12:16 PM, jcv <jv at yeaguy.com> wrote:
>>>       Hi - I am seeing alot of emails regarding libiconv..  Is there a
>>> work
>>>       around for mediatomb per chance??
>>>
>>>       ===>  Building for mediatomb-0.12.1_11
>>>       --- all ---
>>>       /usr/bin/make  all-recursive
>>>       --- all-recursive ---
>>>       Making all in tombupnp
>>>       --- all-recursive ---
>>>       Making all in build
>>>       Making all in build
>>>       --- mediatomb ---
>>>       c++ -I../src  -I../tombupnp/ixml/inc  -I../tombupnp/threadutil/inc
>>>       -I../tombupnp/upnp/inc  -I..    -I/usr/local/include/mysql -pipe
>>>       -fno-strict-aliasing -g -DNDEBUG  -I/usr/local/include
>>>       -I/usr/local/include  -I/usr/local/include    -D_THREAD_SAFE
>>>       -I/usr/local/include  -I/usr/local/include  -I/usr/local/include
>>>       -I/usr/local/include   -O2 -pipe -fno-strict-aliasing   -pthread
>>>        -lmagic -o mediatomb mediatomb-main.o libmediatomb.a
>>>       ../tombupnp/build/libtombupnp.a  -L/usr/local/lib
>>>  -L/usr/local/lib
>>>       -L/usr/local/lib        -L/usr/local/lib -L/usr/local/lib
>>>       -L/usr/local/lib    -pthread    -L/usr/local/lib/mysql
>>> -lmysqlclient_r
>>>       -pthread -lm      -L/usr/local/lib -ljs  -lmagic  -lid3  -lexif  -lz
>>>        -lrt -D_THREAD_SAFE  -pthread  -lavformat -lavutil
>>>        -lffmpegthumbnailer -lexpat  -lmp4v2        -L/usr/local/lib -lcurl
>>>       -lssl -lcrypto -L/usr/lib -lgssapi -lheimntlm -lkrb5 -lhx509
>>> -lcom_err
>>>       -lcrypto -lasn1 -lwind -lheimbase -lroken -lcrypt -pthread -lz
>>> -lcurl
>>>       /usr/bin/ld: : invalid DSO for symbol `libiconv_open' definition
>>>       //usr/local/lib/libiconv.so.3: could not read symbols: Bad value
>>>       c++: error: linker command failed with exit code 1 (use -v to see
>>>       invocation)
>>>       *** [mediatomb] Error code 1
>>>
>>>       make[4]: stopped in
>>>       /usr/ports/net/mediatomb/work/mediatomb-0.12.1/build
>>>       1 error
>>>
>>>       make[4]: stopped in
>>>       /usr/ports/net/mediatomb/work/mediatomb-0.12.1/build
>>>       *** [all-recursive] Error code 1
>>>
>>>       make[3]: stopped in /usr/ports/net/mediatomb/work/mediatomb-0.12.1
>>>       1 error
>>>
>>>       make[3]: stopped in /usr/ports/net/mediatomb/work/mediatomb-0.12.1
>>>       *** [all] Error code 2
>>>
>>>       make[2]: stopped in /usr/ports/net/mediatomb/work/mediatomb-0.12.1
>>>       1 error
>>>
>>>       make[2]: stopped in /usr/ports/net/mediatomb/work/mediatomb-0.12.1
>>>       ===> Compilation failed unexpectedly.
>>>       Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the
>>>       failure to
>>>       the maintainer.
>>>       *** Error code 1
>>>
>>>       Stop.
>>>       make[1]: stopped in /usr/ports/net/mediatomb
>>>       *** Error code 1
>>>
>>>       Stop.
>>>       make: stopped in /usr/ports/net/mediatomb
>>>       root at yeaguy:/usr/ports/net/mediatomb #
>>>
>>>
>>> OK. What version of FreeBSD? Do you have the iconv port installed?
>>>
>>> I have mediatomb running fine under 10.0-RELEASE without the iconv port.
>>>
>>> While the base libiconv is fully POSIX compliant, the port version (GNU
>>> iconv) has
>>> several non-POSIX extensions that a few ports require. I have had no
>>> issues with
>>> mediatomb using base iconv, but your port build was clearly trying to use
>>> a ports
>>> version, /usr/local/lib/libiconv.so.3. The error at least implies that
>>> the library
>>> is corrupt.
>>>
>>> If you don't have libiconv installed, libiconv.so.3 is a remnant from
>>> pre-upgrade,
>>> so you should delete it. If you are not running 10.0, 10-STABLE (recent),
>>> or HEAD,
>>> you should re-install the port.
>>> --
>>> R. Kevin Oberman, Network Engineer, Retired
>>> E-mail: rkoberman at gmail.com
>>>
>>>
>>>
>> Here is my current setup:
>>
>> [vic at yeaguy ~] uname -a
>> FreeBSD yeaguy.com 10.0-RELEASE FreeBSD 10.0-RELEASE #0 r260789: Thu Jan
>> 16 22:34:59 UTC 2014 root at snap.freebsd.org:/usr/obj/usr/src/sys/GENERIC
>>  amd64
>>
>> [vic at yeaguy ~] pkg info | grep libic
>> libical-1.0                    Implementation of the IETF Calendaring and
>> Scheduling protocols
>> libiconv-1.14_1                A character set conversion library
>> [vic at yeaguy ~]
>>
>> [vic at yeaguy ~] locate libiconv.so.3
>> /usr/local/lib/libiconv.so.3
>> [vic at yeaguy ~]
>
>
> And what, if anything, do you get get from 'pkg info -r libiconv-1.14_1'?
>
> When you  went to 10.0, did you rebuild all ports and delete libiconv as
> recommended? I suspect that it should have been deleted, but, as I
> mentioned, a few ports use the extensions in the GNU iconv, so it is
> possible that you need it. With over 1100 ports installed, I hav enot hit
> on one that requires the port.
> -- 
> R. Kevin Oberman, Network Engineer, Retired
> E-mail: rkoberman at gmail.com
> _______________________________________________
> freebsd-ports at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-ports
> To unsubscribe, send any mail to "freebsd-ports-unsubscribe at freebsd.org"
>


Here is some outputs:

[jv at yeaguy ~] pkg info -r libiconv-1.14_1
libiconv-1.14_1:
         php5-iconv-5.4.24_1
         qt4-corelib-4.8.5_2
         pulseaudio-0.9.23_2
         id3lib-3.8.3_5
         xplanet-1.3.0_1
[jv at yeaguy ~] pkg info -r php5-iconv-5.4.24_1
php5-iconv-5.4.24_1:
         gallery3-3.0.9
[jv at yeaguy ~]
[jv at yeaguy ~] pkg info -r qt4-corelib-4.8.5_2
qt4-corelib-4.8.5_2:
         qt4-xml-4.8.5
         doxygen-1.8.3.1_1
         automoc4-0.9.88_3
         qt4-dbus-4.8.5
         qt4-network-4.8.5
         qt4-script-4.8.5
         qt4-sql-4.8.5
         qt4-svg-4.8.5
         qt4-xmlpatterns-4.8.5
         qt4-declarative-4.8.5
         qt4-qt3support-4.8.5
         qt4-clucene-4.8.5
         qt4-help-4.8.5
         qt4-assistant-4.8.5_1
         qt4-designer-4.8.5_1
         qt4-testlib-4.8.5
         qzeitgeist-0.8.0
         soprano-2.9.4
         qca-2.0.3_1
         hupnp-1.0.0_1
         qt4-imageformats-4.8.5
         qt4-qdbusviewer-4.8.5_1
         jovie-4.10.5_1
         kaccessible-4.10.5_1
         kmag-4.10.5
         kmousetool-4.10.5
         kmouth-4.10.5
         akonadi-1.10.3_1
         poppler-qt4-0.24.4
         nepomuk-core-4.10.5_1
         prison-1.0_1
         qjson-0.8.1
         kdepimlibs-4.10.5_3
         kdeadmin-4.10.5
         libkexiv2-4.10.5
         kactivities-4.10.5_3
         qimageblitz-0.0.6_2
         polkit-kde-0.99.1
         kcm-polkit-kde-0.0.20121008
         kactivitymanagerd-4.10.5_3
         phonon-gstreamer-4.7.1
         kde-workspace-4.10.5_2
         kdeartwork-4.10.5_1
         blinken-4.10.5
         analitza-4.10.5
         cantor-4.10.5
         libkdeedu-4.10.5
         kalgebra-4.10.5
         kanagram-4.10.5
         kbruch-4.10.5
         kgeography-4.10.5
         khangman-4.10.5
         kig-4.10.5_1
         ja-kiten-4.10.5
         klettres-4.10.5
         kmplot-4.10.5
         kstars-4.10.5_1
         ktouch-4.10.5
         kturtle-4.10.5
         kwordquiz-4.10.5
         pairs-4.10.5
         parley-4.10.5
         qt4-scripttools-4.8.5
         rocs-4.10.5_1
         step-4.10.5_1
         marble-4.10.5
         libkdegames-4.10.5
         bomber-4.10.5
         bovo-4.10.5
         granatier-4.10.5
         qscintilla2-2.7.2,1
         py27-qt4-core-4.10.3,1
         qt4-iconengines-4.8.5
         qt4-inputmethods-4.8.5
         py27-qt4-gui-4.10.3,1
         py27-qt4-xml-4.10.3,1
         py27-qt4-script-4.10.3,1
         py27-qt4-designer-4.10.3,1
         py27-qt4-network-4.10.3,1
         py27-qt4-opengl-4.10.3,1
         py27-qt4-sql-4.10.3,1
         py27-qt4-svg-4.10.3,1
         py27-qt4-webkit-4.10.3
         py27-qt4-phonon-4.10.3
         py27-qt4-declarative-4.10.3
         okular-4.10.5_3
         qwt5-5.2.3
         py27-qt4-dbussupport-4.10.3
         py27-pykde4-4.10.5_1
         kapman-4.10.5
         katomic-4.10.5
         kblackbox-4.10.5
         kblocks-4.10.5
         kbounce-4.10.5
         kbreakout-4.10.5
         kdiamond-4.10.5
         kfourinline-4.10.5
         kgoldrunner-4.10.5
         kigo-4.10.5
         killbots-4.10.5
         kiriki-4.10.5
         kjumpingcube-4.10.5
         klines-4.10.5
         libkmahjongg-4.10.5
         kmahjongg-4.10.5
         kmines-4.10.5
         knavalbattle-4.10.5
         knetwalk-4.10.5
         kolf-4.10.5
         kollision-4.10.5
         konquest-4.10.5
         kpat-4.10.5
         kreversi-4.10.5
         kshisen-4.10.5
         ksirk-4.10.5
         ksnakeduel-4.10.5
         kspaceduel-4.10.5
         ksquares-4.10.5
         ksudoku-4.10.5
         ktuberling-4.10.5
         kubrick-4.10.5
         lskat-4.10.5
         palapeli-4.10.5
         kdegraphics-mobipocket-4.10.5_1
         kdegraphics-svgpart-4.10.5
         libkdcraw-4.10.5
         kdegraphics-thumbnailers-4.10.5
         kamera-4.10.5
         libkipi-4.10.5
         libkonq-4.10.5
         gwenview-4.10.5_1
         kcolorchooser-4.10.5
         kgamma-4.10.5
         kruler-4.10.5
         kolourpaint-4.10.5
         ksnapshot-4.10.5
         libksane-4.10.5
         ksaneplugin-4.10.5
         dragon-player-4.10.5
         kdemultimedia-ffmpegthumbs-4.10.5_1
         juk-4.10.5
         libkcddb-4.10.5
         libkcompactdisc-4.10.5
         kio-audiocd-4.10.5
         qt4-gui-4.8.5
         qt4-webkit-4.8.5_1
         polkit-qt-0.103.0_1
         phonon-4.7.1
         qt4-opengl-4.8.5
         libdbusmenu-qt-0.9.2_2
         kdelibs-4.10.5_2
         kmix-4.10.5
         kscd-4.10.5
         libktorrent-1.3.1_2
         qca-ossl-2.0.0.b3_4
         qt4-porting-4.8.5
         qt4-uic3-4.8.5
         kopete-4.10.5_1
         telepathy-qt4-0.9.3_1
         krdc-4.10.5
         krfb-4.10.5
         kdenetwork-4.10.5_2
         nepomuk-widgets-4.10.5
         grantlee-0.3.0
         libkgapi-0.4.4
         libkolab-0.4.2
         kdepim-runtime-4.10.5_1
         kdepim-4.10.5_2
         qoauth-1.0.1
         kdeplasma-addons-4.10.5_1
         kate-4.10.5_1
         kdesdk-4.10.5_2
         kdetoys-4.10.5_1
         ark-4.10.5
         filelight-4.10.5
         kcalc-4.10.5
         kcharselect-4.10.5
         kdf-4.10.5
         kfloppy-4.10.5
         kgpg-4.10.5
         kremotecontrol-4.10.5
         ktimer-4.10.5
         kwallet-4.10.5
         print-manager-4.10.5
         superkaramba-4.10.5
         sweeper-4.10.5
         kdewebdev-4.10.5_1
         konsole-4.10.5
         kde-baseapps-4.10.5_1
         cagibi-0.2.0
         kde-runtime-4.10.5_3
[jv at yeaguy ~]








More information about the freebsd-ports mailing list