graphics/rawtherapee: r342622 crashes on HEAD

Rainer Hurling rhurlin at gwdg.de
Thu Feb 6 09:27:16 UTC 2014



Am 06.02.2014 08:52 (UTC+1) schrieb Baptiste Daroussin:
> On Thu, Feb 06, 2014 at 07:03:22AM +0100, Rainer Hurling wrote:
>> Am 05.02.2014 22:20 (UTC+1) schrieb Baptiste Daroussin:
>>> On Wed, Feb 05, 2014 at 09:19:51PM +0100, Matthias Andree wrote:
>>>> Am 05.02.2014 21:08, schrieb Dimitry Andric:
>>>>
>>>>>> #17 0x00000000484c0ee0 in std::__1::locale::id::__next_id () from
>>>>>> /usr/local/lib/libc++.so.1
>>>>>
>>>>> Hmm, is this a ports version of libc++?  I was not aware Baptiste had
>>>>> already committed this? :) 
>>>>
>>>> Yes, it is (as a build requisite, but apparently remained installed on
>>>> the destination machine), because we need to match the libraries that
>>>> the requisites use (Glibmm for one).
>>>>
>>>> I have given up on compiling RawTherapee with clang++ for now, and use
>>>> GCC 4.8 on all systems.  RawTherapee is somewhat demanding, especially
>>>> at higher optimization level, and kills the 10.0-RELEASE base clang and
>>>> Port GCC 4.6 and 4.7, all with internal compiler errors.  Since GCC 4.8
>>>> worked for me, I did not bother to send Gerald the details.
>>>>
>>>> We may want to retry with clang if we've got the next clang version.
>>>> Feel free to use Rawtherapee as compiler system test ;)
>>>>
>>>
>>> try with something like this in libmap.conf
>>> libc++.so.1 /usr/local/lib/libc++.so.1
>>> If that fixes the problem, then a rpath with /usr/local/lib should be set while
>>> building the port
>>
>> Hmm, I am not very familiar with libmapping. After adding it to
>> /etc/libmap.conf I get
>>
>> #rawtherapee	
>> Shared object "/usr/local/lib/libc++.so.1" not found, required by
>> "rawtherapee"
>>
>> Thanks for the tip,
>> Rainer
>>
>>>
>>> regards,
>>> Bapt
>>>
> 
> try reinstalling devel/libc++ and keeping the libmap.conf entry, that should do
> the trick
> 
> as it was a build only dep it may have been removed.
> just remove the line from libmap.conf before reinstalling devel/libc++ and readd
> it once it is installed.

I commented out libmap.conf entry, reinstalled devel/libc++ and readded
libmap.conf entry.

After that, I get the same error, when starting rawtherapee.

In a second step I tried to rebuild graphics/rawtherapee with the entry
in /etc/libmap.conf active. That also fails with:

[..snip..]
/bin/mkdir -p /usr/ports/graphics/rawtherapee/work/.build
Shared object "/usr/local/lib/libc++.so.1" not found, required by "cmake"
*** Error code 1
Stop.
make[1]: stopped in /usr/ports/graphics/rawtherapee
*** Error code 1

Rainer

> 
> Bapt
> 


More information about the freebsd-ports mailing list