x11/nvidia-driver builds; fails install (staging issue?)

David Wolfskill david at catwhisker.org
Sat Feb 1 20:24:08 UTC 2014

> I get the same error on 10.0R amd64 with pkgng.

Hmm...  Well, thanks for evidence that I've not completely lost my
mind.... :-}

> Do you have WITH_NEW_XORG in make.conf on the second system? I think the 
> error above means you should install graphics/libEGL but 
> graphics/libEGL/Makefile says it requires WITH_NEW_XORG.

Come to think of it, I do; yes.  But while it worked for stable/9, on
stable/10, it seems to just be hanging:

===>  Cleaning for nvidia-driver-331.20
*** [all] Stopped -- signal 22
load: 0.13  cmd: make 45803 [select] 1574.44r 0.02u 0.05s 0% 1012k
make: Working in: /common/S3/obj/usr/src
load: 0.17  cmd: make 45803 [select] 1631.71r 0.02u 0.05s 0% 1012k
make: Working in: /common/S3/obj/usr/src
load: 0.05  cmd: make 45803 [select] 7860.23r 0.02u 0.06s 0% 1012k
make: Working in: /common/S3/obj/usr/src

(The "load: ..." & "make: ..." lines were from me hitting ^T.)

> .if ! defined(WITH_NEW_XORG)
> IGNORE=         Please enable WITH_NEW_XORG, libEGL needs libdrm higher 
> then 2.4.24
> .endif
> ....

Hrrmmm.... :-(

David H. Wolfskill				david at catwhisker.org
Taliban: Evil cowards with guns afraid of truth from a 14-year old girl.

See http://www.catwhisker.org/~david/publickey.gpg for my public key.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 964 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20140201/9a9b0e9f/attachment.sig>

More information about the freebsd-ports mailing list