libiconv on 10.0-RELEASE

Guido Falsi madpilot at FreeBSD.org
Sat Feb 1 07:03:32 UTC 2014


On 02/01/14 07:53, nano wrote:
> Seems to be some issues with it:
> https://forums.freebsd.org/viewtopic.php?f=5&t=44644
> https://forums.freebsd.org/viewtopic.php?f=5&t=44659
>
> And my problem:
> https://forums.freebsd.org/viewtopic.php?f=5&t=44658
>
> Can't do UPDATING: 20130904, libiconv has never been on the system.
>
> Not sure whether to allow portmaster to upgrade[*]. Pretty sure
> something will break if I do. What do you suggest?

Hi,

Since then a new commit has changed things a little, it's r341775 [1]

It now allows libiconv to be installed by a few selected ports who 
really need functionality not available in the base implementation of iconv.

>
>
> [*]
> # portmaster -adwv
> ===>>> All >> (4)
>
> ===>>> The following actions will be taken if you choose to proceed:
>          Upgrade php55-iconv-5.5.8 to php55-iconv-5.5.8_1
>          Install converters/libiconv
>          Upgrade nginx-1.4.4_2,1 to nginx-1.4.4_3,1
>          Upgrade owncloud-6.0.0a to owncloud-6.0.1
>
> ===>>> Proceed? y/n [y] n
>
>

 From what I see here I think you can allow it to do that without 
problems for now. I've seen two PRs stating problems with some ports.

The PRs I've indicate that, after such a step, glib20 and exim fail to 
build. These problems need fixing at present.

This applies only to ports compiled on the live system, if one is using 
poudriere or tinderbox they can build anyway(so binary packages have no 
problems), this happens because when using these software each port is 
compiled in a clean environment.

[1] http://svnweb.freebsd.org/ports?view=revision&revision=341775

-- 
Guido Falsi <madpilot at FreeBSD.org>


More information about the freebsd-ports mailing list