Updating linux-f10-pango fails

René Ladan rene at freebsd.org
Tue Oct 15 11:45:43 UTC 2013


2013/10/15 René Ladan <rene at freebsd.org>:
> 2013/10/15 Jerry <jerry at seibercom.net>:
>> I have tried to update the linux-f10-pango port twice; however, it fails each time.
>>
> [...]
>
>> ===>   Generating temporary packing list
>> cd /usr/ports/x11-toolkits/linux-f10-pango/work && /usr/bin/find * ! -path "stage*" -type d -exec /bin/mkdir -p "/usr/ports/x11-toolkits/linux-f10-pango/work/stage/compat/linux/{}" \;
>> cd /usr/ports/x11-toolkits/linux-f10-pango/work && /usr/bin/find * ! -path "stage/*" ! -type d | /usr/bin/cpio -pm -R root:wheel /usr/ports/x11-toolkits/linux-f10-pango/work/stage/compat/linux
>
> Here it installs under ${STAGEDIR}/compat/linux, which is OK...
>
>> 1776 blocks
>> ====> Compressing man pages
>> ====> Running Q/A tests
>> ===>  Building package for linux-f10-pango-1.28.3_1
>> Creating package /usr/ports/x11-toolkits/linux-f10-pango/work/linux-f10-pango-1.28.3_1.tbz
>> Registering depends: linux-f10-cairo-1.8.0_2 linux-f10-xorg-libs-7.4_1 linux-f10-fontconfig-2.6.0 linux-f10-expat-2.0.1 linux-f10-png-1.2.37_2 linux_base-f10-10_7.
>> Registering conflicts: linux-pango-[0-9]* linux-f8-pango-[0-9]*.
>> Creating bzip'd tar ball in '/usr/ports/x11-toolkits/linux-f10-pango/work/linux-f10-pango-1.28.3_1.tbz'
>> tar: could not chdir to '/usr/ports/x11-toolkits/linux-f10-pango/work/stage/usr/compat/linux'
>>
> Here tar gets confused somehow, it wants to pack
> ${STAGEDIR}/usr/compat/linux (note the extra usr/ ), which fails
> consequently.
>
> I'll fire up some poudriere builds, someone told it happened in 9.1
> but not in 9.2 ...
>
They all build fine (i386: 8.3, 8.4, 9.1, 9.2, amd64: 9.2)

You might see the below message, but it shouldn't stop the build:
(pango-querymodules-32:72615): GLib-WARNING **: getpwuid_r(): failed
due to unknown user id (0)
Cannot load module /usr/lib/pango/1.6.0/modules/pango-thai-lang.so:
libthai.so.0: cannot open shared object file: No such file or
directory
/usr/lib/pango/1.6.0/modules/pango-thai-lang.so does not export Pango module API

René


More information about the freebsd-ports mailing list