Bugs in print/hplip assuming Linux file structure

Thomas Mueller mueller6724 at bellsouth.net
Thu Jun 20 11:09:19 UTC 2013

I am trying to configure an HP LaserJet m1212nf MFP and failing possibly because the setup can't find files normal for Linux but different in FreeBSD.

I get error messages such as (running as root):

Searching... (bus=usb, search=(None), desc=0)
error: Failed to find the lsusb command
cat: /etc/issue: No such file or directory
warning:  distro is not found in AUTH_TYPES
cat: /etc/issue: No such file or directory

I also get
warning:  distro is not found in AUTH_TYPES

Now it seems to be just hanging.  I just get |/-\|/-\ ... apparently ad infinitum.

Next step is to try with Ethernet conection, since this multifunction printer supports both USB and Ethernet.

I tried that, no luck.  If I run hp-setup -i
and provide path to .ppd file, it ends with
error: Printer queue setup failed. Please restart CUPS and try again.

No success with FreeBSD with this printer.

If that fails, then I try on my USB-stick installation of NetBSD 6.1 with pkgsrc; pkgsrc and compiling work is done on SATA hard drive.

If that fails, both USB and Ethernet, then on to Linux (Gentoo?).

I can also try with the installation CD (for MS-Windows) with wine-devel in FreeBSD, to see if that works.

If all that fails, then, O Brother, I might get another printer, certainly won't be HP.  I have felt for quite some time now that I don't want to ever again buy anything HP.

I will also want a printer that does not require a proprietary plugin.  Brother? 


More information about the freebsd-ports mailing list