[SOLVED] Re: Can't build Xorg --> make failed for ports-mgmt/pkg

Matthew Seaman matthew at freebsd.org
Fri Jun 14 09:34:38 UTC 2013

On 13/06/2013 15:24, Miguel Clara wrote:
> Than I tried to rebuild just "libdrm" and not xorg, with portmaster
> -f, pkg was mentioned again but this time the update worked and I'm
> now with pkg-1.0.13
> pkg info | grep pkg
> pkg-1.0.13                     New generation package manager
> I'm not exactly sure why it worked now and not before... The only
> difference now is that I made a "make deinstall", I'm glad its
> solved... still having issues with "xorg" but that is a totally
> different discussion!

The errors you were seeing are symptomatic of your build system not
finding pkg.h or libpkg.so.0 in your build tree, but using the installed
copies from the previous version of pkg already installed on your system.

That is works when you remove the instaleld version of pkg means the
problem is incorrect ordering of the include file (-I) or shared library
(-L) search path options.  This works fine if you eg. just check the
sources out of git and run make -- meaning there is something in your
environment overriding the default settings and causing mayhem.



More information about the freebsd-ports mailing list