graphics/gegl 0.1.8 does not build

Mike Harding mvharding at gmail.com
Sun Jan 27 16:55:26 UTC 2013


Oh, and link against it as well, obviously.  Looks like it links
against the old lib now:

...
  CC     gegl-visitable.lo
  CCLD   libgraph.la
gmake[3]: Leaving directory
`/usr/ports/graphics/gegl/work/gegl-0.1.8/gegl/graph'
...

On Sun, Jan 27, 2013 at 7:21 AM, Mike Harding <mvharding at gmail.com> wrote:
> graphviz was just updated, and no longer, apparently, contains a
> library called 'libgraph', it's now, as far as I can tell, called
> 'libcgraph', so the LIB_DEPENDS in the gegl makefile needs to start
> with 'cgraph'
>
> On Sun, Jan 27, 2013 at 4:36 AM, Rainer Hurling <rhurlin at gwdg.de> wrote:
>> On 27.01.2013 12:38 (UTC+2), Koop Mast wrote:
>>> On Sat, 2013-01-26 at 18:40 -0600, ajtiM wrote:
>>>> On Saturday 26 January 2013 14:55:06 Joseph A. Nagy, Jr wrote:
>>>>> On 01/26/13 13:56, Robert Huff wrote:
>>>>>> Joseph A. Nagy, Jr writes:
>>>>>>>   On 01/26/13 12:00, Rainer Hurling wrote:
>>>>>>>   >> ../tools/gobj2dot.rb .. | /usr/local/bin/dot png >
>>>>>>>   >> images/inheritance.png
>>>>>>>   >> Error: dot: can't open png
>>>>>>>   >> Failed to parse ../operations/workshop/max-rgb.c, probably invalid
>>>>>>>   >> utf8
>>>>>>>   >> gmake[3]: *** [images/inheritance.png] Fehler 2
>>>>>>>   >> gmake[3]: Leaving directory
>>>>>>>   >> `/usr/ports/graphics/gegl/work/gegl-0.1.8/docs'
>>>>>>>   >> gmake[2]: *** [all-recursive] Fehler 1
>>>>>>>   >
>>>>>>>   >I just recognized (thanks to David), that the 'real' first error is
>>>>>>>   >not
>>>>>>>   >
>>>>>>>   > a problem with utf8 conversion, but in
>>>>>>>
>>>>>>>   <snip>
>>>>>>>
>>>>>>>   I just wanted to relay I built this on 9.1 with clang w/o any errors.
>>>>>>
>>>>>>    I am unable to get a clean build on
>>>>>>
>>>>>> FreeBSD 10.0-CURRENT #0: Sun Dec 30 12:52:09 EST 2012  amd64
>>>>>>
>>>>>>    and get the same error.
>>>>>>
>>>>>>                            Robert Huff
>>>>>
>>>>> FreeBSD alex-laptop 9.1-RELEASE FreeBSD 9.1-RELEASE #8: Tue Jan 22
>>>>> 14:00:27 CST 2013     root at alex-laptop:/usr/obj/usr/src/sys/ALEX-LAPTOP
>>>>>   amd64
>>>>>
>>>>>   pkg which /usr/local/bin/gegl
>>>>> /usr/local/bin/gegl was installed by package gegl-0.1.8_6
>>>> 9.1-RELEASE FreeBSD 9.1-RELEASE #0 r243826: Tue Dec  4 06:55:39 UTC 2012
>>>> root at obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386
>>>>
>>>> I repeat with clang and gcc. I use portmaster and make but I got the same
>>>> error.
>>>>
>>>>
>>>
>>> I just committed a fix for gegl doc build. I forgot to lift one small
>>> change from the gnome devel repo. Thanks for reporting!
>>>
>>> -Koop
>>
>> Hi Koop,
>>
>> many thanks for the update. It works fine for me.
>>
>> As mentioned in my second mail on this thread, one of the patches in the
>> Makefile is not necessary anymore, because it was updated upstream:
>>
>> --- Makefile.orig       2013-01-27 12:50:15.000000000 +0100
>> +++ Makefile    2013-01-27 13:25:30.000000000 +0100
>> @@ -203,8 +203,6 @@
>>  .endif
>>         ${REINPLACE_CMD} -e 's|\(lua\)\(5\.1\)|\1-\2|g ; s|x86_64|amd64|g' \
>>                 ${WRKSRC}/configure
>> -       ${REINPLACE_CMD} -e 's|/usr/bin/ruby|/usr/bin/env ruby|' \
>> -               ${WRKSRC}/tools/gobj2dot.rb
>>
>>  post-build:
>>  .if ${PORT_OPTIONS:MDOCS}
>>
>>
>> Regards,
>> Rainer
>>


More information about the freebsd-ports mailing list