ghostscript dependency checking, CURRENT + pkgng

George Mitchell george+freebsd at m5p.com
Sun Jan 27 16:08:55 UTC 2013


On a FreeBSD 10.0-CURRENT system on Raspberry Pi, with pkgng installed,
I built print/ghostscript9-nox11 (since I'm not planning to run X11 on
the box).  But when I try to build any of the ports that specify
"USE_GHOSTSCRIPT=yes", "make" in the port's directory tries to satisfy
the ghostscript dependency by trying to build ghostscript9 even though
ghostscript9-nox11 is installed.  If I add

_USE_GHOSTSCRIPT_PKGNAME_SUFFIX=        -nox11

to the Makefile, it "fixes" the problem in an ugly way (although it
didn't fix the problem for print/hplip).

uname: r245840M (image built by Alie Tab on 25 January)
ports: svnversion 308518
pkg -v: 1.0.3

What's the best way to proceed?  I have CUPS installed and it even
works, but I am pretty sure my printer will work better if I can get
print/hplip installed.                          -- George Mitchell


More information about the freebsd-ports mailing list