Two errors each affecting several ports

Kevin Oberman kob6558 at
Tue Jan 1 06:58:28 UTC 2013

On Mon, Dec 31, 2012 at 5:14 PM, Jeffrey Bouquet
<jeffreybouquet at> wrote:
> Reply below.
> --- On Mon, 12/31/12, Kevin Oberman <kob6558 at> wrote:
> From: Kevin Oberman <kob6558 at>
> Subject: Re: Two errors each affecting several ports
> To: "Jeffrey Bouquet" <jeffreybouquet at>
> Cc: freebsd-ports at
> Date: Monday, December 31, 2012, 3:37 PM
> On Mon, Dec 31, 2012 at 3:13 PM, Jeffrey Bouquet
> <jeffreybouquet at> wrote:
>> First error:
>> configure: error: the pkg-config script could not be found or is too old. Make sure it is in your PATH or set the PKG_CONFIG environment variable to the full path to pkg-config
>> (affects ports such as shared-mime-info, esound...)
> pkg-config was replaced by pkgconf back in July. Check
> /usr/ports/UPDATING for the 20120726:entry. Either you didn't relace
> it or, more likely, you did not follow the instructions in UPDATING.
>> Second error:
>> /usr/local/bin/ld: main.o: undefined reference to symbol 'curses version'
>> /usr/local/lib/ could not read symbols: Invalid operation
>> collect2: ld returned 1 exit status
>> *** [mutt] Error code 1
>> ...
>> Which affects several other ports (... mc, vitunes...)
>> ...
>> I tried rebuilding binutils to fix it/them, no difference.  (BTW binutils needs several
>> of its binaries (/usr/local/bin/ to configure/build/install, I fixed that temporarily by
>> copying some of them elsewhere and back as "extra binaries" until reinstalled and
>> overwritten...)
>> ...
>> Each of these three errors may be specific to some arcane setup here.  Posting in
>> the chance that others have fixed it/them and so it is more common problem(s).
> Yes, it appears that something specific to your environment is making
> ports unhappy, but I have no idea what. You don't say what version of
> FreeBSD or whether you have moved to pkgng or are still using the old
> pkg_* tools. Not that I am sure I would know what was going on with
> this information, but it would certainly help. The issue with binutils
> is especially odd. Could you state what "extra binaries" were a
> problem? It almost sounds like some sort of tool chain issue.
> --
> R. Kevin Oberman, Network Engineer
> E-mail: kob6558 at
> 9-STABLE, (r243371); I am not yet pkgng; I've lots in /usr/local/lib/compat
> and some in /usr/local/lib/compat/pkg... the binaries binutils complains about
> are as, ar, and ranlib.; standard $PATH;  I replaced pkg-config with pkgconf ages
> ago.  (Almost wishing for a "wrapper port" that one wraps around a port build to
> point explicitly at which dependency causes an error, or if not, which parameter to ./configure or which patch file in /files/ or which line in the Makefile... almost like a dtrace/strace GUI-something... but specifically for port building.)

What does your PATH look like? Since there should be both /usr/bin
versions of these tools, could your environment be causing the wrong
ones to be used? Normally /usr/bin should precede /usr/local/bin in
the path, but I would hope that the binutils' Makefiles would address
this. Are you doing anything with PREFIX or DESTDIR? the configure
should show:
checking for ar... ar
checking for as... as
etc and:
checking where to find the target ar... just compiled
checking where to find the target as... just compiled
checking where to find the target ranlib... just compiled
checking where to find the target readelf... just compiled

It should create the target executable using the existing ones. it
does not remove any of the files in /usr/bin, so they should always be
R. Kevin Oberman, Network Engineer
E-mail: kob6558 at

More information about the freebsd-ports mailing list