Port update failure | gtk+-2.24.22

Koop Mast kwm at rainbow-runner.nl
Sun Dec 15 18:26:06 UTC 2013


On 15-12-2013 15:49, Jos Chrispijn wrote:
> Koop Mast:
>> You will need to see ports/UPDATING entry 20130929 for details on 
>> this problem
>
> I processed it:
>
>   The graphics/libGL, graphics/dri and related MESA ports have been
>   updated to 9.1 when compiled with WITH_NEW_XORG= set.  It is necessary
>   to remove the old versions of both ports before updating.
>
>   # pkg_delete -f libGL-\* dri-\*
>
>  followed by
>
>   # portmaster -a
>
> After that I processed pkgdb -F and re-ran portmaster -a
>

There are two entries with 20130929. You need to follow the one about 
x11/pixman, sorry about that.

-Koop

> Unfortunately same issue appears again:
>
> Shared object "libpixman-1.so.9" not found, required by 
> "libpangocairo-1.0.so.0"
> Command 
> '['/usr/ports/x11-toolkits/gtk20/work/gtk+-2.24.22/gdk/tmp-introspectDVRffk/Gdk-2.0', 
> '--introspect-dump=/usr/ports/x11-toolkits/gtk20/work/gtk+-2.24.22/gdk/tmp-introspectDVRffk/functions.txt,/usr/ports/x11-toolkits/gtk20/work/gtk+-2.24.22/gdk/tmp-introspectDVRffk/dump.xml']' 
> returned non-zero exit status 1
> gmake[4]: *** [Gdk-2.0.gir] Error 1
> gmake[4]: Leaving directory 
> `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.24.22/gdk'
> gmake[3]: *** [all-recursive] Error 1
> gmake[3]: Leaving directory 
> `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.24.22/gdk'
> gmake[2]: *** [all] Error 2
> gmake[2]: Leaving directory 
> `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.24.22/gdk'
> gmake[1]: *** [all-recursive] Error 1
> gmake[1]: Leaving directory 
> `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.24.22'
> gmake: *** [all] Error 2
> ===> Compilation failed unexpectedly.
> Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the 
> failure to
> the maintainer.
> *** [do-build] Error code 1
>
> Stop in /usr/ports/x11-toolkits/gtk20.
> *** [build] Error code 1
>
> Stop in /usr/ports/x11-toolkits/gtk20.
> ** Command failed [exit code 1]: /usr/bin/script -qa 
> /tmp/portupgrade20131215-34223-1k301jx env UPGRADE_TOOL=portupgrade 
> UPGRADE_PORT=gtk-2.24.19_2 UPGRADE_PORT_VER=2.24.19_2 make
> ** Fix the problem and try again.
> ** Listing the failed packages (-:ignored / *:skipped / !:failed)
>         ! x11-toolkits/gtk20 (gtk-2.24.19_2)    (new compiler error)
>
> --- end of log ---
>
> Perhaps gnome@ can tell us more about it? Untill this update, all 
> portupdates I have run were processed without problems.
>
> Best regards,
> Jos Chrispijn
>
>
>



---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com


More information about the freebsd-ports mailing list