Succsessful Upgrade linux_base-f10-10_6 seems to break... a lot

David Wolfskill david at catwhisker.org
Wed Apr 17 21:56:23 UTC 2013


On Wed, Apr 17, 2013 at 06:37:05AM -0700, David Wolfskill wrote:
> ...
> OK, so .... what did I doi wrong, here...?
> ...

For the archives:  What I did wrong was to have changed /etc/make.conf
by adding

	PREFIX=/common/local

subsequent to having installed some of the linux_* ports and before
installing or updating others, thus creating an inconsistent
environment.

The reason for having done that is that I have the machine configured to
boot from any of 4 possible slices.  I track stable/9 on one slice and
head on another -- daily.  I also update the installed ports daily
(under stable/9).  Just as I want my home directory to be the same
regardless of which slice is booted, I want /usr/local -- the "ports
playground" -- to be the same regardless of which slice is booted.
Therefore, each slice has /usr/local set up as a symlink to
/common/local.  (The filesystem mounted on /common is one of the few
that is "common" to all of the slices.)

So far, I have done the following in an attempt to extricate myself
from the mess; I expect that at some point, I will need to de-install
and re-install all of the linux_* ports -- and maybe quite a few others.

Here's what I did, then:

* Boot from my stable/9 slice into single-user mode.
* swapon -a && fsck -p && mount -a
* pkg_delete -f linux_base-f10-10_6
* vi /etc/make.conf
  I tried changing "PREFIX=/common/local" to "PREFIX??=/common/local"
* cd /compat/linux/lib
* rm libc.so.6 ld-linux.so.2
  These are the symlinks, the creation of which I documented in the
  message to which this is a reply.
* cd /usr/ports/
* pushd emulators/linux_base-f10/
* make -V PREFIX
  This is a test that Tijl Coosemans suggested to determine the effect
  of the make.conf specification.  The result was "/common/local", which
  is *not* what was wanted in this case.
* vi /etc/make.conf
  I removed the "PREFIX" specification entirely.  I have other machines,
  some of which use linux_* ports, and they don't ahve the specification.
* popd
  Back to /usr/ports
* portmaster emulators/linux_base-f10
  This kicked out errors -- couldn't find libpopt.so.0.
  I poked around a bit & found that this was supposed to be provided by
  devel/popt -- but naturally, things were in a confused state because
  of the change of PREFIX.  I elected to just re-install that port, and
  go on a search-and-destroy mission for the bits that were in
  /common/local (by mistake) later.  (I use the laptop for accessing ...
  just about everything I access.  I didn't want to spend longer in
  single-user mode than I need to.)
* portmaster devel/popt
  This worked.  Whew!
* portmaster emulators/linux_base-f10
  This also worked.
* Transition to multi-user mode; observe a certain ... lack of drama.
* Crawl into a corner and lick my wounds. :-}

Well, some time after 10 is branched, I'll be migrating my "stable"
environment to stable/10 anyway, and at that point, I'll need to
de-install/re-install all the ports I want to keep$; maybe I will be
able to manage to avoid repeating this particular mistake.

Peace,
david
-- 
David H. Wolfskill				david at catwhisker.org
Taliban: Evil men with guns afraid of truth from a 14-year old girl.

See http://www.catwhisker.org/~david/publickey.gpg for my public key.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20130417/f8a88956/attachment.sig>


More information about the freebsd-ports mailing list