fixing missing launch icons

Da Rock freebsd-ports at
Sat Nov 10 21:11:28 UTC 2012

On 11/11/12 04:08, Beeblebrox wrote:
> Unfortunately, it was too soon to tag the problem solved. I tried an entry
> like so:
> Encoding=UTF-8
> Name=Emma-SQL
> GenericName=Emma-SQL
> Comment=Emma-SQL Manager
> TryExec=emma
> Exec=emma
> Icon=emma
> Type=Application
> Categories=Programming
> Directory=Programming
> 1. This did not show up anywhere in any sub-menus.
> 2. When I change the desktop session I use from say Gnome to Fluxbox, the
> "Applications" menu changes completely and not only has a very different
> sub-menu (Directory) structure than Gnome but also many of the menu items
> are missing, while some menu icons which were not in Gnome become visible. 
> Emma-SQL did not show up in the Fluxbox menu either, btw.
> 3. <Categories> has influence on this as well, because to fix a
> multiple-entry item I just removed the other categories and the icons
> reverted to a single sub-menu.
> Thanks and Regards.
Don't know precisely why this entry didn't show up (if it is exactly as
it is here), but there is an item that tells it which DE to allow use
under such as Gnome, KDE, etc. I don't have the exact details in front
of me now, but looking at the specs under should shed
light on it.


More information about the freebsd-ports mailing list