[SOLVED] But question still needs to be answered - Re: openjdk6 fails to build - jobs issue?

R Skinner rocky at herveybayaustralia.com.au
Wed Mar 28 11:06:58 UTC 2012

On 03/28/12 01:12, R Skinner wrote:
> I'm trying to build openjdk6 but it is failing as well. Can someone 
> confirm if I'm seeing gmake[x] if this is running as parallel jobs? 
> I'm running every invocation I can find to prevent it 
> (MAKE_JOBS_UNSAFE=true, DISABLE_MAKE_JOBS, env settings), but it 
> insists...
> Its possible something may have changed with the variables, but can't 
> be sure and I don't believe so; at any rate it fails compiling 
> 'hotspot'. I get output with gmake[6], gmake[5], gmake[4]...
I did finally get this to build - I don't know why it worked, but I'm 
not complaining. I ran portsclean -CDD, rebooted, portsnap update, and 
tried again: must have been a patch somewhere in the build; so thank you 
stranger :)

I do still want a clarification, I'm still getting a handle on makefiles 
and building large projects:

What does the gmake[n] mean? Is it parallel builds? I'm not even sure 
what to google for...

More information about the freebsd-ports mailing list