On the usage of ${FILE}

Doug Barton dougb at FreeBSD.org
Fri Mar 2 17:41:13 UTC 2012

On 03/02/2012 07:22, Chris Rees wrote:
> On 2 Mar 2012 13:19, "Wesley Shields" <wxs at freebsd.org> wrote:
>> On Thu, Mar 01, 2012 at 12:38:01PM +0000, Chris Rees wrote:
>>> On 1 Mar 2012 11:26, "Matthew Seaman" <matthew at freebsd.org> wrote:
>>>> Dear all,
>>>> bsd.commands.mk has the following:
>>>> FILE?=          /usr/bin/file
>>>> which is unfortunate, given that ${FILE} is used in several thousand
>>>> ports, generally as a loop control variable for iterating through a
> list
>>>> of files. In fact, I can only find about 8 places where the file(1)
>>>> program is intended.
>>>> This obvious conflict of meanings seems pretty undesirable to me.  Am
> I
>>>> missing something?  Is there any reason to keep the status quo rather
>>>> than changing the bsd.commands.mk variable to FILE_CMD and making the
>>>> corresponding changes in those 8 places?
>>>>        Cheers,
>>>>        Matthew
>>> I think that the loop control variables should be renamed to lower case.
>> Except more of them in uppercase are bound to be added in the future,
>> despite the best warnings not to do so.
> Can I say portlint? ;)

Won't help, as we have a non-trivial number of developers who can't be
bothered to learn the proper way to do things, or even to use a tool as
simple as portlint.

Matthew's proposal is the right way to go.



    This .signature sanitized for your protection

More information about the freebsd-ports mailing list