unassociated shell command

Da Rock freebsd-ports at herveybayaustralia.com.au
Thu Jan 12 01:41:32 UTC 2012

I'm still very new to this, but I'm almost complete on my first port. I 
do have an unusual error which crops up from time to time and I'm 
usually able to fudge along and clear it- but this last little bit won't 

The particular lines in question are as follows:

.if defined(NOPORTDOCS)
         @if [ -d ${WRKDIR}/usr/share/doc ]; then \
                 ${RM} -rf ${WRKDIR}/usr/share/doc; \
PLIST_SUB+="@comment "

and I get the following error make -DNOPORTDOCS install:
"Makefile", line 59: Unassociated shell command "@if [ -d 
${WRKDIR}/usr/share/doc ]; then  ${RM} -rf ${WRKDIR}/usr/share/doc;  fi"
make: fatal errors encountered -- cannot continue

What am I possibly missing? No googling helps, and I've tried many 
different tricks that have worked in the past as ${DIRRM}, ${RM}, 
individual directory/file removal, etc.

The indentation is exactly as in the Makefile.

More information about the freebsd-ports mailing list