Virtualbox 4.1.8 vboxdrv instantly panics on 8-stable i386

Doug Barton dougb at
Thu Feb 23 02:19:22 UTC 2012

On 02/22/2012 15:31, Andriy Gapon wrote:
> on 22/02/2012 12:48 Doug Barton said the following:
>> On 02/22/2012 02:23, Andriy Gapon wrote:
>>> The attached patched should try to grab the memory harder.
>> Same result, different memory address:
>> supdrvGipCreate: failed to allocate the GIP page. rc=-8
>> vboxdrv: supdrvInitDevExt failed, rc=-8
>> module_register_init: MOD_LOAD (vboxdrv, 0xc66e8410, 0) error 12
> OK, now that, thanks to more testers, I realize that this issue is entirely
> i386-specific, I think that I might have been barking at the wrong trees.
> Now something very i386-ish to try to deal with the problem - the usual patch
> file is attached.

This gives much better results. :)  I can kldload the module, and get
this on the command line:
vboxdrv: fAsync=0 offMin=0x3596 offMax=0xa897

VirtualBox works, and I can start win xp (my only 32-bit guest). In 4.0
trying to do 'restart' with XP would hang the XP window forever.... I
tried it with 4.1 and it not only hung the XP guest window, it hung my X
session. Fortunately I was able to Ctrl-Alt-F1 and kill it from the
outside, and didn't have any problems after that. Start/Stop from within
XP worked as expected.

>> ... and not sure it's relevant, but both times I've tried loading these
>> modules it has killed my sound. /dev/mixer goes away, and I have to
>> reboot to get it back. This has never happened before, so I'm pretty
>> sure it's connected.
> No ideas whatsoever at this front.

Didn't happen this time, so I'm guessing some sort of memory corruption
from the failed module load was wiping out the mixer device.

Thanks again,



	It's always a long day; 86400 doesn't fit into a short.

	Breadth of IT experience, and depth of knowledge in the DNS.
	Yours for the right price.  :)

More information about the freebsd-ports mailing list