x11-wm/windowmaker: saving session not possible any more

Rainer Hurling rhurlin at gwdg.de
Wed Feb 22 18:47:38 UTC 2012

On 19.02.2012 07:36 (UTC+1), Rainer Hurling wrote:
> On 18.02.2012 23:10 (UTC+1), Doug Barton wrote:
>> On 02/18/2012 04:08, Rainer Hurling wrote:
>>> Many thanks for the update of WindowMaker. I really appreciate it! As
>>> far as I was able to test until now it works greats.
>>> The only problem I run into is, that it is not possible to save the
>>> workspaces (sessions) any more. With prior versions I was able to save
>>> opened xterms or other windows on serveral workspaces (menu workspace:
>>> save session) and restore them when starting WindowMaker again.
>>> Is it only me having this problem or is there something wrong with the
>>> new port (or even the sources)?
>> I tried this myself (I don't usually use that option) and your report
>> seems to be accurate. I bcc'ed you on a message to the wmaker-dev list,
>> we'll see what they have to say. Feel free to subscribe yourself if
>> you'd like to join in.
> Thank you for taking time for this. I will follow the discussion over
> http://news.gmane.org/gmane.compw.window-managers.windowmaker.devel
> and only subscribe if I have something to contribute.

Hi Doug,

it seems I found a workaround for getting the session restored after 
restarting windowmaker.

Commenting out a flag in src/startup.c does it:

--- src/startup.c.orig  2012-02-14 20:36:01.000000000 +0100
+++ src/startup.c       2012-02-22 19:20:43.000000000 +0100
@@ -761,7 +761,8 @@

                 /* If we're not restarting, restore session */
-               if (wPreferences.flags.restarting == 0 && 
+               if (wPreferences.flags.restarting == 0)
+                   /* && !wPreferences.flags.norestore) */

                 if (!wPreferences.flags.noautolaunch) {

I seems to be sufficient to comment out either the first term 
(wPreferences.flags.restarting == 0), or the second term 
(!wPreferences.flags.norestore). In both cases restoring the session 
work. Only both at once (with &&) does not work. I have no clue what is 
going wrong here.

Perhaps you have an idea? Should we make a patch for that as a workaround?


> Rainer
>> Doug

More information about the freebsd-ports mailing list