math/R vs. devel/pcre

David Wolfskill david at
Wed Feb 15 17:53:35 UTC 2012

I had a problem rebuilding math/R this morning after updating
devel/pcre; I'm wondering if there's something obvious (to folks
other than me) that I did incorrectly.

Absent extenuating circumstances, I update the installed ports on
my laptop daily -- after updating FreeBSD itself -- running stable/8

I use portmaster as my "weapon of choice" for handling the ports.

Per ports/UPDATING, before updating any other ports this morning,
I ran:

	portmaster -w devel/pcre

which completed without incident.

I then ran

	portmaster -ad --index

to update everything else.

The list of ports to be updated was:

===>>> The following actions will be taken if you choose to proceed:
        Upgrade p11-kit-0.10 to p11-kit-0.11
        Upgrade perl-5.12.4_3 to perl-5.12.4_4
        Upgrade apache-2.2.22_4 to apache-2.2.22_5
        Upgrade gimp-app-2.6.11_5,1 to gimp-app-2.6.12,1
        Upgrade glib-2.28.8_3 to glib-2.28.8_4
        Upgrade iso-codes-3.29 to iso-codes-3.32.2
        Upgrade goffice-0.8.17 to goffice-0.8.17_1
        Upgrade netpbm-10.35.83 to netpbm-10.35.84
        Upgrade php5-5.3.10 to php5-5.3.10_1
        Upgrade php5-mysql-5.3.10 to php5-mysql-5.3.10_1
        Upgrade php5-session-5.3.10 to php5-session-5.3.10_1
        Upgrade php5-xml-5.3.10 to php5-xml-5.3.10_1
        Upgrade py27-gimp-app-2.6.11 to py27-gimp-app-2.6.12
        Upgrade py27-subversion-1.7.2 to py27-subversion-1.7.3
        Upgrade subversion-1.7.2 to subversion-1.7.3
        Upgrade R-2.14.1 to R-2.14.1_1
        Upgrade gimp-2.6.11,2 to gimp-2.6.12,2
        Upgrade help2man-1.40.5 to help2man-1.40.6
        Upgrade nmap-5.61.t4 to nmap-5.61.t4_1
        Upgrade ted-2.21_3 to ted-2.21_4
        Upgrade wireshark-1.6.5 to wireshark-1.6.5_1

===>>> Proceed? y/n [y] 

===>>> Starting build for ports that need updating <<<===

which (as indicated) I accepted.

All went well up to math/R, the build of which ran for a while, then whined:

gcc46 -std=gnu99  -I../../src/extra/bzip2   -I../../src/extra   -I. -I../../src/include -I../../src/include  -DHAVE_CONFIG_H  -fopenmp -fpic  -O2 -pipe -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing -c version.c -o version.o
gcc46 -std=gnu99  -I../../src/extra/bzip2   -I../../src/extra   -I. -I../../src/include -I../../src/include  -DHAVE_CONFIG_H  -fopenmp -fpic  -O2 -pipe -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing -c vfonts.c -o vfonts.o
gfortran46  -fopenmp -fpic  -O -Wl,-rpath=/usr/local/lib/gcc46 -c xxxpr.f -o xxxpr.o
gcc46 -std=gnu99 -fpic -shared -fopenmp -Wl,-rpath=/usr/local/lib/gcc46  -o CConverters.o CommandLineArgs.o Rdynload.o Renviron.o RNG.o agrep.o apply.o arithmetic.o array.o attrib.o base.o bind.o builtin.o character.o coerce.o colors.o complex.o connections.o context.o cov.o cum.o dcf.o datetime.o debug.o deparse.o deriv.o devices.o dotcode.o dounzip.o dstruct.o duplicate.o engine.o envir.o errors.o eval.o format.o fourier.o gevents.o gram.o gram-ex.o gramLatex.o gramRd.o graphics.o grep.o identical.o inlined.o inspect.o internet.o iosupport.o lapack.o list.o localecharset.o logic.o main.o mapply.o match.o memory.o model.o names.o objects.o optim.o optimize.o options.o par.o paste.o platform.o plot.o plot3d.o plotmath.o print.o printarray.o printvector.o printutils.o qsort.o random.o raw.o registration.o relop.o rlocale.o saveload.o scan.o seq.o serialize.o size.o sort.o source.o split.o sprintf.o startup.o subassign.o subscript.o subset.o summary.o sysutils.o unique.o util.o version.o vfonts.o xxxpr.o ../unix/Rembedded.o ../unix/libunix.a ../appl/libappl.a ../nmath/libnmath.a  ../extra/bzip2/libbz2.a  ../extra/tre/libtre.a    -L../../lib -lRblas -lgfortran -lm -lquadmath  /usr/local/lib/ -L/usr/local/lib /usr/local/lib/ -Wl,-rpath -Wl,/usr/local/lib -lreadline -lpcre -llzma -lz -lm -liconv -licuuc -licui18n
mkdir /common/ports/math/R/work/R-2.14.1/bin/exec
gcc46 -std=gnu99  -I../../src/extra/bzip2   -I../../src/extra   -I. -I../../src/include -I../../src/include  -DHAVE_CONFIG_H  -fopenmp -fpic  -O2 -pipe -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing -c Rmain.c -o Rmain.o
gcc46 -std=gnu99 -export-dynamic -fopenmp -Wl,-rpath=/usr/local/lib/gcc46 -o R.bin Rmain.o -L../../lib -lR -lRblas
../../lib/ undefined reference to `_pcre_valid_utf8'
collect2: ld returned 1 exit status
*** Error code 1

Stop in /common/ports/math/R/work/R-2.14.1/src/main.
*** Error code 1

Stop in /common/ports/math/R/work/R-2.14.1/src/main.
*** Error code 1

Stop in /common/ports/math/R/work/R-2.14.1/src.
*** Error code 1

Stop in /common/ports/math/R/work/R-2.14.1.
*** Error code 1

Stop in /common/ports/math/R.
*** Error code 1

Stop in /common/ports/math/R.

===>>> make failed for math/R
===>>> Aborting update

===>>> Update for math/R failed
===>>> Aborting update


[End of log excerpt]

Since I was fairly sure that the remaining ports had no dependency
on math/R, I updated them, then re-tried math/R; symptoms were the

Here's what I have for config options for math/R:

d134(8.2-S)[24] dirs
d134(8.2-S)[25] make showconfig
===> The following configuration options are available for R-2.14.1_1:
     ATLAS=off "Use ATLAS instead of BLAS/LAPACK"
     ICU=on "Use ICU for collation in multibyte locales"
     NLS=on "Build with NLS support"
     PCRE_PORT=on "Use PCRE port instead of bundled source"
     THREADS=on "Build a multithreaded R"
     GHOSTSCRIPT=on "Enable the [dev2]bitmap() graphics devices"
     JPEG=on "Enable the jpeg() graphics device"
     LETTER_PAPER=on "Use US Letter paper"
     LIBR=on "Install libR and a dynamically-linked R"
     PANGOCAIRO=on "Enable cairo and pango in graphics devices"
     PNG=on "Enable the png() graphics device"
     TCLTK=on "Use Tcl/Tk (for the tcltk package)"
     X11=on "Enable the X11() graphics device"
     INFO_MANUALS=on "Install GNU info manuals"
     PDF_MANUALS=off "Install PDF manuals (requires TeX)"
===> Use 'make config' to modify these settings

Here's "uname -a" output as of the time I was doing the above:

FreeBSD 8.2-STABLE FreeBSD 8.2-STABLE #326 231755M: Wed Feb 15 03:52:51 PST 2012     root at  i386

The above work was done within script(1), so I have a typescript
available, if folks would find that useful.

Clues welcome; thanks in advance.

David H. Wolfskill				david at
Depriving a girl or boy of an opportunity for education is evil.

See for my public key.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url :

More information about the freebsd-ports mailing list