Two errors each affecting several ports

Kevin Oberman kob6558 at
Mon Dec 31 23:37:37 UTC 2012

On Mon, Dec 31, 2012 at 3:13 PM, Jeffrey Bouquet
<jeffreybouquet at> wrote:
> First error:
> configure: error: the pkg-config script could not be found or is too old. Make sure it is in your PATH or set the PKG_CONFIG environment variable to the full path to pkg-config
> (affects ports such as shared-mime-info, esound...)

pkg-config was replaced by pkgconf back in July. Check
/usr/ports/UPDATING for the 20120726:entry. Either you didn't relace
it or, more likely, you did not follow the instructions in UPDATING.

> Second error:
> /usr/local/bin/ld: main.o: undefined reference to symbol 'curses version'
> /usr/local/lib/ could not read symbols: Invalid operation
> collect2: ld returned 1 exit status
> *** [mutt] Error code 1
> ...
> Which affects several other ports (... mc, vitunes...)
> ...
> I tried rebuilding binutils to fix it/them, no difference.  (BTW binutils needs several
> of its binaries (/usr/local/bin/ to configure/build/install, I fixed that temporarily by
> copying some of them elsewhere and back as "extra binaries" until reinstalled and
> overwritten...)
> ...
> Each of these three errors may be specific to some arcane setup here.  Posting in
> the chance that others have fixed it/them and so it is more common problem(s).

Yes, it appears that something specific to your environment is making
ports unhappy, but I have no idea what. You don't say what version of
FreeBSD or whether you have moved to pkgng or are still using the old
pkg_* tools. Not that I am sure I would know what was going on with
this information, but it would certainly help. The issue with binutils
is especially odd. Could you state what "extra binaries" were a
problem? It almost sounds like some sort of tool chain issue.
R. Kevin Oberman, Network Engineer
E-mail: kob6558 at

More information about the freebsd-ports mailing list