UPDATING

Royce Williams royce at tycho.org
Mon Dec 24 14:32:01 UTC 2012


On Mon, Dec 24, 2012 at 4:30 AM, Chris Rees <crees at freebsd.org> wrote:

> On 24 December 2012 11:31, Chris Whitehouse <cwhiteh at onetel.com> wrote:
> > On 24/12/2012 06:52, Anton Afanasyev wrote:
> >>
> >> I second this.
> >> While it may have made sense to include the "rebuild all ports. Here's
> an
> >> example of how" initially, including three versions of the rebuilding
> >> commands is a tad too much, and so replacing the wordiness with a simple
> >> "ACTIONS:" tag kind of thing would make the message much more concise.
> >>
> >>
> >> On Sun, Dec 23, 2012 at 12:49 PM, Кулешов Алексей<rndfax at yandex.ru>
> >> wrote:
> >>
> >>
> >>> Good morning, everyone!
> >>>
> >>> Instead of thousand words like these:
> >>>
> >>> 20121211:
> >>>    AFFECTS: users of graphics/ImageMagick
> >>>    AUTHOR: bdrewery at FreeBSD.org
> >>>
> >>>    The ImageMagick library has been updated to version 6.8.0-7.  Please
> >>>    rebuild all ports that depend on it.
> >>>
> >>>    If you use portmaster:
> >>>          portmaster -w -r ImageMagick
> >>>    If you use portupgrade:
> >>>          portupgrade -fr graphics/ImageMagick
> >>>    If you use pkgng with binary packages:
> >>>          pkg install -fR graphics/ImageMagick
> >>>
> >>>
> >>> may be it would be useful for port upgrade programs to see information
> >>> like this:
> >>>
> >>> 20121211:
> >>>    AFFECTS: users of graphics/ImageMagick
> >>>    AUTHOR: bdrewery at FreeBSD.org
> >>>    ACTION: REBUILD_DEPS
> >>>
> >>>    ... some words for interested one ...
> >
> >
> > Could I put in a request as a lowly user to keep the wording? For various
> > reasons I haven't used any of the above commands (still on 9.0R with
> default
> > packages and tinderbox before that) and there have been a lot changes
> > recently. Keeping the wording helps those of us who aren't yet up to
> speed
> > with the new systems.
>
> I think we need to keep in mind people for whom English is an
> additional language... parsing ACTION; REBUILD_DEPS is a lot easier
> for them than a few paragraphs.
>
> However, in this case I don't see how the wording could be simplified.
>
>
I think that part of the original poster's point was that instructions on
how to rebuilt dependencies could be generically included once (perhaps at
the top?) and then repeatedly included by reference where needed.

Royce


More information about the freebsd-ports mailing list