Should USE_UNZIP be deprecated?

Mikhail T. mi at aldan.algebra.com
Sat Dec 22 03:14:14 UTC 2012


tar(1) has been able to extract .zip files for quite a while now. Is it 
time to deprecated USE_UNZIP knob?

The ports, that use it without also altering 
EXTRACT_{BEFORE|AFTER}_ARGS, can, probably, be in the first wave -- 
simply removing the knob from them should do the trick...

For the rest, portlint can be taught to warn about it...

Or do we still support OS-releases, where tar was not so advanced? Thanks,

    -mi



More information about the freebsd-ports mailing list