portmaster 3.13.13 real endless loop "Waiting on fetch & checksum.."

G. Paul Ziemba pz-freebsd-ports at ziemba.us
Wed Aug 29 19:46:40 UTC 2012

I think my original reply did not go out on 8/27, so here it is:

dougb at freebsd.org (Doug Barton) writes:
>On 08/25/2012 16:58, G. Paul Ziemba wrote:
>> The second scenario exhibits the problem. Here, I delete the distfile
>> and just run portmaster without -F. The fetch completes, but portmaster
>> does not seem to notice.
>Can you try that second test again, and add -D to the command line?
The good news is that I removed the distfile and than ran
"portmaster -D devel/gsoap", and it worked. The bad news is
that I killed it before it installed, went back and deleted
the distfile again and deleted devel/gsoap/work and ran just
"portmaster devel/gsoap", and that also worked. I must have
done something in the meantime that caused it to work.
I didn't do anything with that specific port, and portmaster lists
it as a "root" port, so I'm not sure what would have made a difference.
I was monkeying aroung with libpng and some other ports, but didn't keep
an exact record. Argh.
One thing I did notice was that in the failed scenario (described
in my previous message), the tmp file named /tmp/<foo>DI-FILES<bar>
was incomplete, but in the run today with -D, the corresponding
tmp file was much larger (48851 bytes) and had a lot more ports listed.
No idea if that's significant.
G. Paul Ziemba
FreeBSD unix:
12:46PM  up 2 days, 32 mins, 8 users, load averages: 1.05, 1.26, 1.66

More information about the freebsd-ports mailing list